x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

HTML-5 Package size

We're currently re-working a project for HTML-5 distribution. I've been doing various tests with different projects and I can't seem to get an acceptable file size for the packaged content. I've grabbed Tappy Chicken, created a build with it and I get a very nice and small 30mb.

When I try to compile an empty scene (new project, new empty level), I can't get lower than 150mb! When I compile a scene from our project, with all content, I get pretty much to the same result, ~150mb.

I've compared Tappy Chicken package settings to my settings and they are pretty much the same.

Any idea why a default, empty scene, will create a package to be 150mb? (Unreal 4.12.5)

Are there any settings that I need to tweak in any of the .ini files to improve the packaging process?

Thanks in advance for your help.

Product Version: UE 4.12
Tags:
more ▼

asked Aug 26 '16 at 02:37 PM in Packaging & Deployment

avatar image

chalde
46 3 4 8

avatar image chalde Aug 26 '16 at 04:25 PM

After 1 more hour of testing and comparing/tweaking the INI files to match the settings from Tappy Bird, I am still stuck with results that don't make sense.

Filling up a scene with 100 of spheres, a player controller, and some point lights, the output HTML folder is 157 mb... The UE4game.js is taking 80mb alone, while the "map" itself slightly increases when I had more content to it.

Can't figure out why my UE4game file is so big? Is there a compression checkbox that I'm not seeing?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Chalde,

Thanks for bringing this to our attention, I have since entered JIRA UE-35333 for this issue. I tested HTML5 packaging alongside Windows, iOS and Android. I did not notice such an increase in size as I did with HTML5.

However as some guidelines, we suggest moving any non-utilized files from your project prior to packaging. Make sure that the textures you're using aren't taking up too much memory either.

HTML5 isn't necessarily a mobile platform however it is more closely related to mobile than to an OS therefore, we suggest using the 'Reducing APK Package Size' for some tips.

I'd also suggest looking at this link for Reducing Your Package Size.

Thanks!

more ▼

answered Aug 30 '16 at 07:54 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Thought I'll share more tests I've been doing:

  • Created a "Top Down" project in Unreal 4.10 and in 4.12.5

In 4.10: HTML5 size package: 40 mb In 4.12: HTML5 size package: 161 mb

I also tried with settings compressed and uncompressed PAK in 4.12. Same size. UE4Game.js doesn't get compressed to a js.gz file like it does in 4.10.

Is compression broken in 4.12 or do I have to force it somewhere a different way?

more ▼

answered Aug 30 '16 at 02:40 PM

avatar image

chalde
46 3 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have also been very annoyed at the immensely huge package sizes.

Does this option help at all?

alt text

more ▼

answered Aug 26 '16 at 07:58 PM

avatar image

CleanCut
2.1k 67 84 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I've tried with and without creating compressed package. Same result. The funny thing is, if you look at Tappy Bird deffault project settings, it's set to not even create a compressed package, yet, the size is 30 mb compared to my empty scene for 150mb.

I also went manually and unchecked all plugins, same result.

more ▼

answered Aug 27 '16 at 01:46 PM

avatar image

chalde
46 3 4 8

avatar image CleanCut Aug 27 '16 at 09:36 PM

There's got to be a trick to it that simply isn't documented well. I hope someone enlightens us.

avatar image chalde Aug 29 '16 at 05:33 PM

I was hoping to find an answer in the forum (now that's it's back) but all links point to the same documentation, which doesn't really mention anything useful.

Pretty frustrating.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question