x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[VR] Drawn Debug shapes are offset, doubled and moving when moving HMD

Hey there,

so I downloaded the latest 4.13 Preview, which is currently Preview 3.

REPRO STEPS

  1. Use 4.13 Preview 3 (can also happen in 4.12 etc, but I found it in 4.13 P3

  2. Create a new Project and use the "Virtual Reality" Template (can also happen in other templates, not tested)

  3. After you created the Project, open the "MotionControllerMap"

  4. Now, locate the "BP_MotionController" Blueprint and open it

  5. In there, locate the "TraceTeleportDestination" function and open it

  6. In here, you will see a big node called "Predict Projectile Path"

  7. Extend the Node and select a Draw Debug Type. I used "For Duration"

  8. Now start the Game in VR and activate the Teleport Process, by pressing the Touchpad UP on one of your MotionControllers

  9. Do NOT release it! Notice how it's offset to the actual Cyan colored spline.

  10. Also notice, that if you keep the Controller fixed at one point and rotate the HMD (Vive!), the Debug stuff moves and rotates

This is clearly visible on the Computer Screen! In the Vive HMD itself (When wearing it), you will see the following:

Left eye sees only one offset Debug to the right of the spline and right eye will see one that fits the Spline and a SECOND one that is offset to the left.

WHAT SHOULD HAPPEN?

The Debug should cover the same path as the cyan colored Spline, as the "Vector Array", which the Node returns, is used for these. Also the Debug shouldn't move when you rotate your HMD. And the Debug Drawing shouldn't be duplicated.

WHAT HAPPENS INSTEAD?

Debug is offset to the right/left (depending on eye). Debug moves when rotating the HMD. One display of the Vive HMD (right eye) sees two traces where one actually is correct!

ADDITIONAL INFORMATION

Instead of turning on the Draw Debug Type, you can also use a For Each Loop on the Vector Array and use "Draw Debug Sphere" with each point of the Array. The result will be the same.

My guess is, that this happens for all Debug renderings here. The Predict Projectile Path just happens to show the problem.

VIDEO REFERENCE

This is only showing the view from the screen of my PC. For Vive HMD you will need to test it yourself.

https://www.dropbox.com/s/q9hcvu3o4i5ksg6/terad.mp4

Any more information? Just ask me (:

Product Version: UE 4.13 Preview
Tags:
more ▼

asked Aug 26 '16 at 02:50 PM in Bug Reports

avatar image

eXi
6.8k 333 185 468

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello eXi,

After reading over you post, it appears that this is a known issue. I have provided a link to the public tracker. I believe the issue mentioned is covered under this report. Thank you for the additional information.

Link: https://issues.unrealengine.com/issue/UE-34600

Make it a great day

more ▼

answered Aug 26 '16 at 05:27 PM

avatar image

Rudy Q ♦♦ STAFF
47.4k 545 132 524

avatar image eXi Aug 26 '16 at 05:30 PM

Hey Rudy,

Thanks for the heads up, but the post you linked talks about line traces. Also it mentions that the debug only appears in one eye.

So the issue is maybe related but not at all the same.

(: cheers!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have the same issue. It is caused by having Instanced Stereo turned on in the Rendering settings.

Turning it off fixes the problem, obviously at the cost of not having the instanced stereo speed boost.

more ▼

answered Sep 01 '16 at 07:29 AM

avatar image

avinashlobo
46 9 9 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question