x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Android Textures not Tiling

This is my first attempt at developing for Mobile, We've done a number of architectural visualizations for desktop and our textures/Materials work fine. The devices I'm testing on: Moto X Pure, Nexus 6. They still look great in the editor, but whenever I launch or package for Android the textures don't tile. They seem to sit in the center of the UV and stretch across the rest:

alt text

Here's what they look like in the editor:

alt text

Our textures are all:

  1. Square

  2. Power of two (either 512 or 1024)

  3. set to wrap

  4. Materials are using Custom UVs

alt text

I was setting the UVs in 3DS Max as box projection at 1' cubed so that the textures would be uniformly scaled across meshes. I thought that might be the problem so I remapped all the meshes using a flattened UV map and the textures seem to be doing the same thing:

alt text

I've looked all over the forums and I can't seem to find a solution. Anyone have any Ideas?

Product Version: UE 4.12
Tags:
more ▼

asked Aug 26 '16 at 03:41 PM in Packaging & Deployment

avatar image

jpurcell
8 2 5

avatar image saeedc Aug 26 '16 at 04:55 PM

have you changed UV scale of those textures?

avatar image jpurcell Aug 26 '16 at 05:03 PM

Yes, by using a texture coordinate in the Custom UV. It's a pretty simple material. alt text

avatar image saeedc Aug 26 '16 at 05:15 PM

Are those textures shared wrap?

I use the same method as you and works fine.

try something like this: and remove custom UVs alt text

m.png (63.2 kB)
avatar image jpurcell Aug 29 '16 at 03:44 PM

Just tried removing the custom UVs, looks the same.

I thought I read somewhere in the Unreal documentation that Custom UVs were preferred for mobile.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi jpurcell,

You may need to update your Android_NDK_Root environment variables to point to the newer Android NDK. Here is a screen shot of that location. alt text I would recommend downloading Revision 11c as I know that one works https://developer.android.com/ndk/downloads/revision_history.html

Once You have updated your NDK try deploying.

Hope that helps,

Ed Burgess

ndk.png (70.6 kB)
more ▼

answered Sep 02 '16 at 02:38 PM

avatar image jpurcell Sep 08 '16 at 05:35 PM

Unfortunately, those are the versions I was already running. I've tried uninstalling and reinstalling codeworks and pointing to the newer versions before packaging. and finally this morning, updating to 4.13.0 and trying to package with either 11c and 12b. They all have similar logs.

FailedPackageNDK12bFailedPackageNDK11c

avatar image Ed Burgess ♦♦ STAFF Sep 08 '16 at 06:48 PM

Hi jprucell,

After some investigating I noticed you had "multiple definitions of GetHMD()" in your log files. I found an issue that is essentially the same as yours. https://answers.unrealengine.com/questions/482101/413-gearvrgooglevr-plugins-conflict.html

A bug report has been made and you can review the status of it here: https://issues.unrealengine.com/issue/UE-35691

Hope that helps,

Ed Burgess

avatar image jpurcell Sep 08 '16 at 07:57 PM

Since we have no interest in using GearVR in the near future, we've turned that plug in off for now, and it is packaging successfully.

I can also confirm that packaging in 4.13 does solve the texture issue. thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi jpurcell,

Based off the screenshots you provided your issue looks very similar to this Hub post: https://answers.unrealengine.com/questions/435741/tiling-impossible-with-google-vr-plugin.html

It looks like the issue has been addressed in 4.13 and is now fixed. You can always verify this by making a copy of your project in 4.13 and testing!

hope that helps,

Ed Burgess

more ▼

answered Aug 29 '16 at 08:42 PM

avatar image jpurcell Aug 30 '16 at 05:18 PM

I'm trying to test this on 4.13 preview 3, but the game will not launch or package

avatar image jpurcell Aug 30 '16 at 05:22 PM

Here's a copy of the log

link text

shade_mobile_v1.log (469.7 kB)
avatar image Steve Hardister ♦♦ STAFF Aug 30 '16 at 06:26 PM

If you created the 4.13 version of the project by opening a copy of the 4.12.5 version in UE4.13, try these troubleshooting steps:

  1. Run a Map check for all maps in your project and fix any errors.

  2. Right-click on the Content folder in the Content Browser and select fix up redirectors in folder.

  3. If the first two steps do not resolve the issue, make a back up of, then delete the Saved, Intermediate, and Config folders from your Unreal Project folder.

  4. Open the output log and clear (so you're starting with a blank log)

  5. Try packaging again and if it fails, cut and paste contents in a new text file and link here

avatar image jpurcell Aug 31 '16 at 05:22 PM

Thanks for looking into this, I tried all the steps above and It's still not packaging. Attached is the package section of the new log.

FailedPackageLog

avatar image Steve Hardister ♦♦ STAFF Aug 31 '16 at 07:20 PM

What OS are you using and do you have any 3rd Party Plugins installed?

avatar image jpurcell Aug 31 '16 at 07:49 PM

I'm using windows 10. I don't think I have any 3rd party plugins installed, The only plug in added was the GoogleVR, oculus, and steam VR plugins through the plug ins menu.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question