x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging error - unknown... pulling out my hair

Hello,

For the life of me I cannot figure out or even narrow down what the problem is. I have a project that I'm trying to package, but within a couple of seconds it immediately errors out with the message, "PackagingResults:Error: Error Unknown Error". I've searched through a bunch of other posts regarding packaging errors but still can't find the bug. Here's my log output: https://docs.google.com/document/d/1mNbBEIhmNPKjsVLBF52sfZifaqm6bfJWAJg3h2bkLWI/edit?usp=sharing

And I've included a screenshot of my project settings below.

I would greatly appreciate any help anyone could offer, even if it's just pointing me in a general direction. Thank you!

alt text

Product Version: UE 4.12
Tags:
projectsettings.png (106.6 kB)
more ▼

asked Aug 27 '16 at 07:36 PM in Packaging & Deployment

avatar image

Mikeriosphilly
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi, I found this in your log file : "WARNING: Visual C++ 2015 toolchain does not appear to be correctly installed. Please verify that "Common Tools for Visual C++ 2015" was selected when installing Visual Studio 2015."

It seems like Common Tools for Visual Studio are not installed, you can manually install them by creating a new C++ project in Visual Studio or you can run VS installer again and select Modify and then just select Common Tools at the bottom of the list.

You can also take a look at Ue4 documentation on how to set up Visual Studio for Ue4 http://docs.unrealengine.com/latest/INT/Programming/Development/VisualStudioSetup

more ▼

answered Aug 27 '16 at 09:07 PM

avatar image

Blue man
181 7 13 19

avatar image Mikeriosphilly Aug 28 '16 at 08:18 PM

Thank you for your help! Unfortunately it's still not working. I re-installed Visual Studio with the Common Tools, and then I created a new C++ project and had it download even more stuff, rebooted, then tried packaging again, but it didn't work. Here's my log output now: https://docs.google.com/document/d/1m3yCzR0Abp7T0KORzfqI3EMZUZjwAOf3D0AD5vu2bfg/edit?usp=sharing

I can create a new project and package that just fine, but for some reason this one will not package. I might have to just start over, import my content one by one, and see where it breaks. I'll post here if I find anything, in case anyone else runs into the same issue.

avatar image Sean L ♦♦ STAFF Aug 29 '16 at 03:03 PM

You seem to be getting an error related to it being unable to determine module type. Have a look at this thread and see if the suggested solutions help resolve your issue: https://answers.unrealengine.com/questions/451348/ubt-unable-to-determine-module-type.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question