x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Project building/compiling suddenly fails due to FMOD binaries issues

We've been using FMOD for quite a while, plugin version 1.08. No issues what so ever, can compile, package and play the game. Then suddenly tonight everything is going wrong. Neither the engine nor the plugin were updated or changed prior to that.

Symptoms:

1) First, I tried packaging development build as usual. In-editor build was successful, but starting the game.exe led to this error:

alt text

We have not added any reference to FMOD in code, we only use it in BPs except for one code pre-load that was added weeks ago and worked fine.

2) I then tried building the development again, thinking something went wrong. The exactly same build failed this time with following errors: http://pastebin.com/2uRfpXaj

3) Lastly I decided to try deleting all binaries in project/plugin folder, re-generating project VS files and recompile it through Visual Studio. Rebuilding the game project in VS now gives this error:

alt text

Nothing works any longer, although I can still play game in edtor, and for some reason compile project in debug config but not development. Any ideas what on earth went wrong there?

Product Version: UE 4.9
Tags:
more ▼

asked Aug 28 '16 at 04:43 PM in Packaging & Deployment

avatar image

Araklaj
50 5 10 15

avatar image Matthew J Aug 29 '16 at 05:33 PM

Hello Araklaj,

I've never seen this particular problem before but it does definitely seem like a problem where the plugin is having issues compiling. Have you checked for the file that is mentioned in that first error listed in your picture? fmodL64_vc.lib

First just check if it exists, if it does, be sure that it isn't set to read-only. Also, check the output log itself in Visual Studio to see if there may be more details about these errors or what's going wrong in the compilation process.

avatar image Araklaj Aug 29 '16 at 05:40 PM

Hi Matthew. The file does exist and wasn't set to read-only. We were unable to solve this issue, so I just started going through revisions of source C++ files. All of them, including newest one worked.

Still no idea what happened there as I previously pulled latest versions multiple times, but it seems to be working again. Sometimes, it's like FMOD is running on black magic or something..

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

We were unable to solve this issue, so I just started going through revisions of source C++ files. All of them, including newest one worked. Still no idea what happened there as I previously pulled latest versions multiple times, but it seems to be working again.

more ▼

answered Aug 29 '16 at 05:41 PM

avatar image

Araklaj
50 5 10 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question