x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

UMG retainer box washing colours out on 3D Widget

Hey Guys,

So we're trying to create a visual effect using the new retainer boxes, and it works great. However when you use retainer boxes with UMG elements for 3D world widgets, the colours get oddly washed out. They seem to work fine when added to viewport, but acting strangely in world.

We've broken it down step by step to make sure we weren't doing anything odd, and the ONLY difference is the use of the retainer box. Attached is an image explaining the situation, we've used as simple material as possible, with as simple a UMG as possible. The image shows a standard 3D widget on the left, and a 3D widget using retainer box on the right.

As stated before, retainer boxes on viewport widgets work fine. It may not be completely clear from the image, but all elements of the UMG get washed out, not just images, but text, borders etc.

alt text

Product Version: UE 4.12
Tags:
more ▼

asked Aug 29 '16 at 01:54 PM in Rendering

avatar image

Ungalyant
102 11 15 23

avatar image Acrossfy Apr 01 '17 at 11:01 PM

Hey Mate! Did you solve your issue with RetainerBox and 3D Widget? Bug report was closed as "Won't Fix" without any explanation. But I have the same issue and still can't find solution..

avatar image Ungalyant Apr 04 '17 at 04:33 PM

I BELIEVED that the submitted answer was the correct fix, but I wasn't really dealing with the issue at the time. We came back to this a few weeks ago and actually found the same as you, changing it to non-srgb (and therefore the texture samplers in the shader as linear color) had some effect, but didn't really change much. We actually ended up just compensating for this in our shader. Not a satisfying answer at all, I know.

avatar image Acrossfy Oct 03 '17 at 03:28 PM

It didn't work for me (I mean submitted answer). But this bug was fixed in 4.16, and now it's broken in 4.18p2 again - https://answers.unrealengine.com/questions/712257/418p2-retainer-panel-causes-textures-in-3d-widgets.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I had this same problem today, it seems that the RetainerBox materials sends input (the texture parameter) and expects output as linear RGB, so having a texture sampler with a sRGB texture will look bad. what did it for me was setting the texture as not sRGB in the texture import settings.

I'd consider this is a bug so you should submit a bug report.

more ▼

answered Dec 27 '16 at 09:43 PM

avatar image

BoteRock
36 2 5 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question