x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Continuous short freezes while working in the Editor

I did not have this issue in 4.11.2, but always had these short (~5-10 sec) freezes in the Editor in 4.12.5.

The same thing is happening in 4.13p3 (in all previews actually).

While my PC is quite old, I did not have this issue prior to 4.12

My hardware specs are the following:

AMD Phenom x3 2.2Ghz

8Gb RAM

Nvidia GF 670 GTX 2Gb

Windows 7 Pro 64-bit

Product Version: UE 4.13 Preview
Tags:
more ▼

asked Aug 29 '16 at 08:28 PM in Bug Reports

avatar image

motorsep
373 39 48 66

avatar image Slavq Aug 29 '16 at 08:33 PM
  • Same here, my specs:

i5 3570K 3.40GHz @4.40GHz

8GB RAM

NVIDIA GTX 760

Windows 10

avatar image Stephen Ellis ♦♦ STAFF Aug 29 '16 at 08:35 PM

For reference, this was originally reported on the 4.13 Preview forum thread, along with a few users who said they are experiencing various freezes: https://forums.unrealengine.com/showthread.php?119130-Unreal-Engine-4-13-Preview&p=586742&viewfull=1#post586742

This issue may be difficult to track down, and may benefit from input from multiple users who experience similar issues. This is not a widespread issue for all users, so thank you for your patience and understanding.

avatar image Deathrey Aug 30 '16 at 12:14 AM

Same here. Several second freezes during which CPU usage is spiking for UE4Editor.exe

  • I7-4770k @ 3.5 Ghz

  • 16 GB ram

  • GTX 770

  • 4.12.5 and 4.13 p1 p2 p3

  • Launcher version

Worth noting that i've started experiencing freezes not since a specific UE4 version was deployed, but rather after launcher update, that happened around 11-14 august.

avatar image motorsep Aug 30 '16 at 01:37 AM

Oh, you nailed it - I read your post here, closed my launcher while keeping Editor opened and bam! - all freezes are gone. Editor works as smooth as butter.

It's not a solution to close launcher as I might need to switch a project or open another project to migrate assets into current one.

I am still working in 4.12.5 for my current project, so someone has to test it in 4.13p3

avatar image Deathrey Aug 30 '16 at 09:51 AM

Hmm I've ran the engine with launcher closed for a few hours and did not get any freezes either. Not sure how conclusive it is so far.

avatar image VassiliosC Aug 30 '16 at 09:25 AM

I closed the launcher and then sciulpt the Landscape in UE4 Editor and have a freeze ;;;!!

avatar image Sean L ♦♦ STAFF Aug 30 '16 at 01:38 PM

Hey everyone,

I get the feeling that the landscape sculpting could be a different issue, so could you please open a new thread for that @VassiliosC

As far as the other freeze goes, please reply back to let me know if closing the launcher has resolved the freezes, as I have not been able to reproduce this on my end.

avatar image Deathrey Sep 03 '16 at 07:41 PM

Good day Sean. I can confirm that having launcher closed gets rid of freezes, while keeping it open results in random editor freezes once in a while.

avatar image TimSkijwalker Sep 06 '16 at 10:12 AM

I also have this issue at the moment. Any word on a fix?

avatar image Sean L ♦♦ STAFF Sep 06 '16 at 06:36 PM

Hello,

Have you tried working with the Launcher closed to see if that resolves the freezes? We've been unable to reproduce the issue on our end at this time, so there hasn't been a ticket entered. If you can provide a set of repro steps so that we can reproduce it on our end, that would be great as well!

avatar image motorsep Sep 06 '16 at 07:10 PM

With Launcher opened I get continuous frequent freezes. With Launcher closed I still get those short freezes, just less often.

avatar image Slavq Sep 06 '16 at 07:35 PM

Same here, it's still freezing even with Launcher closed, just less often. It's quite 'random', so I guess that the best way to reproduce this is to work an ~hour on some project on machine with similar specs to the ones listed above. ... + Maybe operating system also matters, mine is Windows 10.

avatar image motorsep Sep 12 '16 at 06:04 PM

Why is this marked as resolved?!

avatar image Slavq Sep 02 '16 at 01:17 PM

I can confirm that having launcher opened causes the freezes. Official 4.13 here. For now I'm just closing the launcher every time, but I hope it'll be fixed in the future :)

avatar image Sean L ♦♦ STAFF Sep 06 '16 at 07:16 PM

Hello everyone,

Everyone who has not already posted their specs, please provide your DxDiag so I can take a look and see if there are any hardware correlations.

Thanks!

avatar image TimSkijwalker Sep 06 '16 at 08:25 PM

It's been happening for me after importing assets from an older Unreal engine version. (but it could also be because I opened the launcher to add those assets. haven't tried without. it's very random because later it was working fine again... after restarting everything.)

Edit; I think my launcher was open for the entire time. (I remember paragon updating)

[link text][1] [1]: /storage/temp/105921-dxdiag.txt

dxdiag.txt (90.6 kB)
avatar image Sean L ♦♦ STAFF Sep 09 '16 at 05:16 PM

Thank you all for posting your specs. I have another question that I'd like those who are experiencing the freeze to answer:

When you are experiencing these freezes, are you noticing any increase in memory? Go to Edit->Editor Preferences->Miscellaneous and enable the Show Framerate and Memory option to keep track of this. You can also use Task Manager. Please provide the exact numbers if you are seeing an increase.

Thanks!

avatar image motorsep Sep 09 '16 at 08:04 PM

So, I switched from 4.12.5 to 4.13 for my Sky Light tests - freezing is horrible with launcher opened and with launcher closed. I'd say freezed x2 - x3 times more often than 4.12.5.

I turned on that option you suggested - it stopped freezing as often (launcher closed) and when I experienced freezing memory value did not change.

avatar image motorsep Sep 11 '16 at 04:41 AM

Bizarre behavior - every 2-3 sec I get 5-10 sec freezes. It's impossible to work like that :(

Worth mentioning that 4.11.2 was rock solid release - no freezes ever.

avatar image Slavq Sep 09 '16 at 10:14 PM

Just freezed for ~5s, and with no memory increase (checked in Task Manager)

avatar image Slavq Sep 10 '16 at 01:06 AM

I've just encountered almost a minute-long freeze! CPU usage went from ~15-20% to ~40% during freeze, but memory usage stayed at ~60%, no increases here.

PS. That was without launcher opened.

avatar image Deathrey Sep 10 '16 at 07:31 PM

Yep, sadly just got a freeze with launcher closed.

avatar image motorsep Sep 10 '16 at 12:08 AM

Something I noticed right now - I got freezes to become less frequent after doing nothing but simply navigating around and turning on that option.

Then I tweaked materials and replaced old materials on some meshes - bam! freeze after freeze to the point deeming UE4 unusable :(

P.S. ~30 min later still having freezes. After I closed Material Editor window freezes significantly subsided.

P.P.S. It feels like 4.13 constantly compiling shaders in the background. Btw, I not longer see a pop-up says and counting shaders when I change materials. It simply applies/saves and the, without any popup it goes into grind.

avatar image motorsep Sep 11 '16 at 02:10 PM

Disregard all the "positive" things I said above - I opened project fresh (after restarting PC) this morning as still get constant and continuous freezes. 4.13 is impossible to work with :(

avatar image motorsep Sep 12 '16 at 02:40 AM

One last thing to mention - my DerivedDataCache folder is in my project's folder (I edited .ini file so it's created where I need for it to be created and not on C: drive) as I am running out of free space on C: drive (where UE4 places DerivedDataCache folder by default).

Not sure if it makes any difference, but I figured it's something worth mentioning.

avatar image Slavq Sep 12 '16 at 03:19 PM

Hmm, I have over 30 GB left on C: and still get the freezes. By the way, I've noticed that the editor tends to freeze pretty hard if we e.g. minimize it, go browsing web for ~5 min and then go back to editor. In my case it sometimes takes a 10-20 seconds to un-freeze and get back to usable state. This wasn't happening in e.g. 4.11, as I remember.

PS. Just freezed for ~15s. after just selecting Spline component in blueprint.

avatar image Matt.Williams Sep 12 '16 at 06:02 PM

This type of behavior can possibly occur if the drive that your DDC is located on has a lot of read/write activity. You can use our DDC Docs to try and move your DDC to a new location. This will cause hitches as you work if you don't pre-build your DDC, so use the build commands in the Docs.

I suspect what's happening is that you're experiencing hitches whenever the engine has to compile something new and store it in the DDC. The behavior when this happens would be a hitch when first loading an asset, then it no longer hitches for that asset after that.

-Matt W.

avatar image motorsep Sep 12 '16 at 06:05 PM

Not even sure what DDC stands for. I am working on 1 PC, no other PCs networked with it (and I don't have any other PCs).

avatar image Slavq Sep 12 '16 at 06:07 PM

In my case I don't use any DDC, single local PC machine, only me.

avatar image motorsep Sep 12 '16 at 06:45 PM

From the docs, "Pass -ddc=noshared on the command line" - how do we do that if we run engine from Launcher and not from cmd line or shortcut ?

avatar image Sean L ♦♦ STAFF Sep 12 '16 at 08:06 PM

Hey motorsep,

Here is a doc that will show you how to run the editor through the command line: https://docs.unrealengine.com/latest/INT/GettingStarted/RunningUnrealEngine/#runningtheeditorfromthecommandline

avatar image motorsep Sep 12 '16 at 11:08 PM

Sorry I wasn't clear - I know how to use cmd line ;)

I wanted to add the argument, somehow, so I could still run Editor from Launcher, but it would be launched with -ddc=noshared (from the Launcher, not cmd)

avatar image Deathrey Sep 14 '16 at 02:08 PM

I've been monitoring disk read/wrtie activity during freezes. There was none coming from UE4 / Launcher affiliated processes. Only a CPU usage spike.

avatar image motorsep Sep 14 '16 at 02:18 PM

Have you tried running Editor with -ddc=noshared ?

It sort of solved freezes for me, but not 100% sure yet. The problem with that (and I haven't messed with working with materials yet) was that when I applied new material to a static mesh, it took forever to appear and Editor was choppy. So I had to disable "show folder"in content browser, select all assets there and right click on them to load. Took a while, including compiling 9,000+ shaders.

So I am not sure whether I have to do this nonsense every time I start engine with -ddc=noshared or if it was one time thing.

avatar image Matt.Williams Sep 14 '16 at 10:37 PM

Hey motorsep,

The build DDC steps I gave you are the way to compile all of those shaders ahead of time. With your method, you shouldn't have to do it every time, but I would recommend that you close the editor immediately after any long shader compile takes place. This will "lock it in", so to speak. If you were to crash instead of closing normally, you'd have to do it all over again.

Building may solve some of your LOD freezes, unless it's a completely unrelated issue.

Also, your changes to the BaseEngine.ini file should essentially similar to -ddc=noshared. You shouldn't need to use -ddc=noshared anymore. It's up to you if you'd like to extend the "MinimumDaysToKeepFile" variable too. You'll notice there are some important settings missing from the [NoShared] section that are present in [InstalledDerivedDataBackendGraph]. Just make sure you have these same .ini changes in all of your engine versions too.

-Matt W.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

So, I probably should have worded that better, but DDC is the exact thing you mentioned in your previous comment...Derived Data Cache.

The DDC essentially this(from the doc I linked):

The Derived Data Cache (DDC) stores versions of assets in the formats used by the engine and its target platforms, as opposed to the source formats artists create that are imported into the editor and stored in .uasset files. Content stored in the DDC is disposable in that it can always be regenerated at any time using the data stored in the .uasset file. Storing these derived formats externally makes it possible to easily add or change the formats used by the engine without needing to modify the source asset file.

So, what this sounds like, to me, is that you've updated your project from 4.12 to 4.13. There are a lot of custom shaders/textures/assets that you worked on and developed in 4.12. As you created these assets, they were compiled and stored in the 4.12 DDC (found here: C:\Users\USERNAME\AppData\Local\UnrealEngine\4.12\DerivedDataCache).

After updating to 4.13, all of your custom assets are not a part of the 4.13 DDC. So, if you don't "Build" the assets in that project with the build command found in the docs, then it's going to do it one at a time as you load each asset in your project. In turn, this causes the editor to freeze while it caches that asset.

So, you were asking how to launch from the command line. This is how to build the DDC in 4.13 for your project.

  1. Open CMD

  2. Locate the UE4Editor.exe file in "Program Files (x86)\Epic Games\4.13\Engine\Binaries\Win64"

  3. Drag the exe into the CMD window

  4. Add a space

  5. Locate your .uproject

  6. Drag it into the CMD window

  7. Add a space

  8. Type -run=DerivedDataCache -fill

  9. Hit Enter

  10. Go get coffee

  11. When it's finished, try opening your project again.

If you still get freezes, let me know and we'll go from there.

-Matt W.

more ▼

answered Sep 12 '16 at 08:36 PM

avatar image Matt.Williams Sep 12 '16 at 08:42 PM

So, as you've stated, it's pointing to a DDC in your project folder. Can you send me the ini file where you made that change?

avatar image motorsep Sep 12 '16 at 11:06 PM

This is the file I edited: https://drive.google.com/open?id=0BwE6dxM0O2PscW00ODVFX1MyNzg

Did the same for 4.11.2 btw and didn't have this issue with freezing.

avatar image motorsep Sep 13 '16 at 12:13 AM

Interesting development - I ran the engine with -ddc=noshared and it took a while to load, had all the shaders compiling and stuff.

So far it's not freezing unless LODs on models get swapped.

I'll work in it more and report back.

avatar image Slavq Sep 14 '16 at 10:43 PM

My project was converted from 4.12, so I ran these cmd commands (... -run=DerivedDataCache -fill, enter, getting coffee, etc.) and the freezes are gone for now! I haven't tested it long enough though, but it seems like it might be a solution for the freezes. Thank you!

avatar image motorsep Sep 16 '16 at 07:12 PM

So, I finally did that too. Then loaded project through the launcher. Didn't have any freezes, until I switched to ES2 preview (which recompiled bunch of shaders) and re-baked lighting. After that I was back to square one :(

P.S. Restarted engine, loaded project - freezes began as soon as I selected my ISM actor.

avatar image motorsep Sep 19 '16 at 03:18 AM

I deleted Intermediate, Saved, Binaries, Build and DerivedCache folders from my project, reopened it and it had no freezes until I selected a static mesh on the level.

The filled cache as described above - no difference.

Minor additional details - I experience a freeze when selecting an actor on the level. After freeze is over, if I don't do anything but navigate, no additional freeze happens. Same goes for changing something on selected actor (change material for example)

Also my project has persistent level with 2 streaming levels.

Anyhow, I give up :( I find myself fighting 4.13 more than working on my project.

avatar image Sean L ♦♦ STAFF Sep 19 '16 at 06:07 PM

Hey motorsep,

Have you made any changes to your config files at all? It seems that the solution Matt provided worked for Slavq, so I'd be curious to see what the differences are on your end that are causing you to continue to experience the freezing.

avatar image motorsep Sep 19 '16 at 06:37 PM

I provided modified BaseEngine.ini above. Basically when I installed UE 4.13, I right away went into the .ini and replaced %whatever% (there were 2 macros that were not %GAMEDIR% and that was making UE4 create DDC in my user dir on C: drive) with %GAMEDIR%. That's all I did.

avatar image Matt.Williams Sep 20 '16 at 05:33 PM

Did you modify the BaseEngine.ini in 4.12 too or just for 4.13?

We really are running out of avenues to investigate this and cannot continue to invest time in something that appears to be isolated to your computer. I know we've had other users chime in, but their issues are either resolved or they aren't responding anymore.

We have no way of telling if this is some piece of software you have installed that is conflicting with the engine, hardware issues, or just low spec hardware (your CPU is below our recommendations and RAM is right at the minimum). It could very well be DDC issues, which is why I still have a few recommendations.

Please either A) Uninstall the launcher and reinstall it on another drive(and reinstalling engine versions there as well) or B) Make some space on C: and revert your ini files to default

-Matt W.

avatar image motorsep Sep 24 '16 at 06:17 AM

I think I found what causes freezes - InstaLOD plugin.

I created new project using FPS template and just started messing with stuff in the scene. Had no freezes at all.

Then I copied InstaLOD plugin from my actual project into this newly created FPS template and almost immediately I began experiencing freezes.

Going to report it to the author. Can't wait for UE4 to have native LOD generation tools - as it is engine is complex and with 3rd party plugins it's hard to track what causes issues (between UE4 and installed plugins).

P.S. I deleted plugin, and now clean project freezes as badly as the core project I am working on. I give up. Maybe it is my hardware. Who knows...

avatar image its_manny Sep 24 '16 at 09:09 AM

Hi there, I am one of the developers of InstaLOD. I've already replied to your question on the forums, but I wanted to reply here as well.

As you pointed out yourself, this is unrelated to InstaLOD. Infact the integration of LOD into UE4 is by among the best in the industry that I have seen so far. UE4 basically just invokes our API when LOD needs to be generated, InstaLOD by itself does not act on it's own. Everything is actively invoked from UE4 and stored in it's local cache. InstaLOD by itself is a passive plugin and relies on the API points provided by UE4. So there is close to nothing that InstaLOD can do that could cause any harm to UE4.

But I did read the thread, and it might be that you're running out of memory and that your system might be doing a lot of swap work. I'd also be careful with modifying the engine.ini files. A lot can easily broken with moving the data cache folders and modifying their timeouts. Depending on the system and project, rebuilding the UE4 datacache with all materials, geometry and shaders can take hours.

It's quite unfortunate that UE4 doesn't work as it should for you, but maybe a clean reinstall of Windows might help. And thanks for clearing up that it's unrelated to InstaLOD

avatar image motorsep Sep 26 '16 at 02:21 PM

It could be my hardware. Hopefully when I upgrade I won't have these issues.

avatar image Deathrey Sep 28 '16 at 11:49 AM

It is definitely not related to any plugins. Could you also check if having stat (stat fps, etc) display enabled or disabled makes any difference?

avatar image motorsep Sep 28 '16 at 01:30 PM

Nope, it doesn't. I literally ran out of ideas. Something changed in UE4 from 4.11 to 4.12/4.13 that make it freeze on older hardware. So I guess I can only wait 'till I upgrade and see if that solves the issue.

avatar image Deathrey Sep 29 '16 at 11:44 AM

How about source control? Running P4V in your project by any chance?

avatar image motorsep Sep 29 '16 at 01:20 PM

Nope, I don't have any version control.

Funny thing is I had to load 4.11 yesterday to check something, and I didn't have any freezes. So while I do agree my hardware is ancient (except for my GPU), 4.11 doesn't have the issue. So something changed in 4.13 that makes it really hard to use on older hardware. Oh well, UE4 was always regarded as hi-end engine so I really should upgrade my PC.

avatar image riot Sep 29 '16 at 11:56 AM

I'm experiencing this same problem and in my case, I've noticed that until i activate stat fps/unit/foliage the freezes are quite sparse. Once i type that command, they happen every 2 secs which makes it impossible to work.

Also, I've noticed that turning off all engine plugins which were not needed for my project (all that contained ios/android/oculus rift in their name) helped considerably: before the freezes happened when doing almost everything. After disabling the plugins, the freezes became way less frequent and only very frequent after enabling stat commands.

avatar image motorsep Sep 29 '16 at 01:21 PM

What plugins did you disable ? Some plugins are obviously necessary and I can't just disable them.

avatar image riot Sep 29 '16 at 04:19 PM

i don't know what most plugins do, what i did however is disable all those plugins whose names contain "android/ios/oculus rift" words, since i could tell they were related to those platforms and therefore not neede for my project, which is windows-only. basically i was trying to reduce as much CPU usage as possible. not sure if that's a good way to do it, but it helped reduce the constant freezes so that made me happy

avatar image TimSkijwalker Sep 30 '16 at 05:25 AM

My issues are resolved =) Derived Data Cache fixed it for me. (Sorry for not responding for a while, i've been incredibly busy)

Thanks for all the support everyone! (and in particular the staff for being so on top of an issue that occurs for a few people)

avatar image Deathrey Sep 30 '16 at 04:35 PM

Right, another wild guess. Whoever is still getting freezes, would you mind checking if presence of landscape in the level currently loaded makes any difference?

avatar image Drogsterfloggy Oct 31 '16 at 01:53 AM

I deleted my rant... long story in short... I upgraded my RAM to 16gb from 8gb and the problem has gone away in 4.13 but remains in 4.12. This is a strange problem but I can live without 4.12. v4.11 still runs OK as well.

For reference, this is my spec now: i5 3570K - 16gbRAM - SSD - ASUS GTX970 Strix - Win7

avatar image motorsep Oct 31 '16 at 04:27 PM

So while you have CPU usage at 100% during freezes and you weren't hitting RAm limits, increasing RAM resolved it? I don't see any logic behind this :/

avatar image Drogsterfloggy Oct 31 '16 at 09:53 PM

No, neither do I unless it's because the RAM was slightly faulty or incompatible in some way. It was 1333Mhz and the new RAM is 1600Mhz but it really is the only thing that has stopped the glitches. But like I said it still happens in 4.12.

EDIT: I correct myself, it is still doing it in 4.13 as well. Takes a few minutes to kick in but then happens more often until UE4 is completely unusable.

avatar image motorsep Nov 10 '16 at 12:52 AM

Interesting discovery - I converted my project to 4.14p3 and it seems to have no freezes. Only freezes up when I add something new to the scene from Content folder. So it seems to me 4.13 had some serious memory management issues.

Once 4.14 release is out and I can use FMOD with it, I can determine for sure whether 4.14 freezes or doesn't.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question