x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[BUG] FBX Reimport only imports one object

Hi,

I've looked through the forums and answers hub and couldn't find anything adressing this, so I thought I'd report this bug.

When I'm reimporting meshes from FBX files, only the first object in the file will be reimported. So if I have file with a hierarchy like this:

     A
        - B
        ....
     X

Only object A will be reimported, the rest is just gone from the asset. The only way I can fix the asset is by completely deleting it and then setting it up from scratch again.

I'm using Blender 2.77. I've reimported the files in Blender to see if the exporter screws up, but the imported data was fine.

Steps to produce the error: 1. Create two objects (e.g. cubes) in Blender 2. Export the to fbx by selecting them and then choosing "selected only" as export option 3. Drag and drop the file in the unreal content browser 4. Checkout that the import worked 5. Hit reimport

Hopefully this bug is reproducible.

My environment:

  • Blender 2.77

  • Unreal Editor Version: 4.12.5-3039270+++UE4+Release-4.12

  • Windows 10 Pro

Cheers, Todd

Product Version: UE 4.12
Tags:
more ▼

asked Aug 29 '16 at 10:10 PM in Bug Reports

avatar image

ToddW
8 1 2 6

avatar image Adam Davis STAFF Aug 30 '16 at 09:35 PM

Hi ToddW,

Are you importing the actors all as one object or individual actors?

avatar image ToddW Sep 02 '16 at 12:34 PM

Hi Adam,

sorry for the long reply time! I'm importing them as one object.

avatar image Adam Davis STAFF Sep 02 '16 at 02:22 PM

Instead of dragging to the content browser, try using the Import button. When you do this, you can optimize your import settings. Once you've imported, try re-importing, do you see the same error occur?

avatar image ToddW Sep 03 '16 at 02:54 PM

Have tried that but the reimport is still broken. These are the settings I use: screenshot

settings.png (69.5 kB)
avatar image Adam Davis STAFF Sep 07 '16 at 07:08 PM

Unfortunately, I have not been able to reproduce this on my end using the steps provided. Do you have a sample asset that this is occurring with? I'd be happy to take a look and see what may be going on.

avatar image ToddW Sep 10 '16 at 12:03 AM

Again sorry for the slow reply! Yes I do! I get the error with this file: https://drive.google.com/file/d/0B6MzEV7x4K2oRXU3eDJNTjExUlk/view?usp=sharing

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi ToddW,

After doing some digging, it appears the error you are experiencing is being caused by your export settings from Blender. I re-exported the file and it appeared without the error you are seeing. I've attached a .zip containing an image of my export settings from Blender along with an update FBX, please test this and see if it works correctly on your end.

link text

cube.zip (49.5 kB)
more ▼

answered Sep 12 '16 at 02:37 PM

avatar image ToddW Sep 12 '16 at 03:26 PM

Hi Adam,

thanks for investigating! Your fbx works. However I've tried the export using your settings with my export and the reimport failed again. It has to do with the version of Blender. When naming my Blender version above I missed that I'm actually 2.77a not 2.77. I've just tried the export with the new 2.78rc and it works. So I guess the exporter of 2.77a is just broken.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question