x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Issues on Building 4.12.5 from source in VS2015

Hi,

Following the steps provided in Building Unreal Engine from Source, I am trying to build UE4. However, it seems to get stuck (see the image attached).

alt text

This status continues for several hours (at least 10 hours, yet to finish), while the progress bar shows the building is in progress.

Even though the building time depends on the specification of system, the time (10 hours or even more) is too unreasonable. (My Specs: i7-4790, 16GB RAM )

I don't know what happened and what should I do to fix it.

Any help would be appreciated :-)

Product Version: UE 4.12
Tags:
未命名.jpg (84.4 kB)
more ▼

asked Aug 30 '16 at 12:40 PM in Installation & Setup

avatar image

Streliteela
11 1 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Streliteela,

It is not very common, but sometimes the compiler in Visual Studio will get stuck on a file. If you have not already done so, could you try stopping and starting the build again? This should only build any remaining files that have not yet been built, so files that have already been completed successfully will not be built again.

Tim

more ▼

answered Aug 30 '16 at 07:11 PM

avatar image Streliteela Sep 01 '16 at 06:11 AM

Hi Tim Lincoln ♦♦,

Thanks for your timely reply. Unfortunately, I am running into another problem when I stopped and try to build it again.

alt text

It had taken even longer than 12 hours to build ShaderCompileWorker yesterday, but it is not over yet. It is abnormal and seems to get stuck again. Today, I try it again, but hit the same obstacle T_T

avatar image Tim C ♦♦ STAFF Sep 01 '16 at 09:32 PM

That certainly does sound unusual. Just to confirm, you are not getting any errors or build failures at all, the build process just gets stuck on one file indefinitely?

Would you be able to let me know what your Solution Configuration and Solution Target settings in Visual Studio are? Also, could you provide the dxdiag information for your computer?

Tim

avatar image Streliteela Sep 02 '16 at 11:17 AM

Only got errors when I ran Setup.bat and GenerateProjectFiles.bat. But I tried to build UE after successfully downloading the files. Solution Configuration: Development Editor. Solution Platform: Win64

alt text

buildconfig.jpg (91.9 kB)
avatar image Tim C ♦♦ STAFF Sep 02 '16 at 02:23 PM

What were the errors that you saw when you ran Setup.bat and GenerateProjectFiles.bat?

Tim

avatar image Streliteela Sep 05 '16 at 03:55 AM

Sorry for the late reply.

The error got from Setup.bat is showed below.

alt text

Others are net-related.

The source code I built was cloned from GitHub.

I also downloaded the source code as a zip from GitHub and tried to built it. Setup.bat and GenerateProjectFiles.bat ran quickly without any errors, much less time than those from the cloning version. However, it seemed to get stuck in the building of UE4, too.

alt text

failedsetup.jpg (46.5 kB)
zipsourcebuilt.jpg (144.0 kB)
avatar image Streliteela Sep 06 '16 at 03:26 AM

In the process of building source code (.zip), each time it got stuck, I stop and restart the building. It stopped completely with 2 errors...

alt text

Is it imcompatible with VS2015-update 2 in win7 ? I used VS2015-update2 in win7.

alt text

avatar image Tim C ♦♦ STAFF Sep 07 '16 at 01:56 PM

Hi Streliteela,

Just a quick question. Are you using a 32-bit version of Windows 7? The error message that you showed should only occur if you are trying to build the Engine on a 32-bit OS.

It would also be helpful if you could provide your dxdiag information so we can have a better idea of your system specs since we have not been able to reproduce this here (yet).

Tim

avatar image Streliteela Sep 09 '16 at 04:00 AM

Hi Tim Lincoln ♦♦,

I install the 64-bit version of Windows 7.

Partial dxdiag information is showed below.

alt text

dxdiag.jpg (62.6 kB)
avatar image Tim C ♦♦ STAFF Sep 10 '16 at 04:53 PM

Thank you for providing that information. I do not see anything in the dxdiag information that would normally result in the issue that you are experiencing.

There also should be no problem with using Visual Studio 2015 Community with Update 2. I am currently still on Update 1, but the Engine was recently updated to work with Update 3. If you are downloading the source code from the release branch (currently 4.13.0), it should work with any update to Visual Studio 2015.

If you try again and get to the point where the build fails, could you please provide the last 15-20 lines from your output log? The actual cause of the build failure should be in there.

Could you also please download this file, place it on your desktop, remove the .txt extension, then run the file? This will create a new info.txt file with information related to your Visual Studio installation. Upload that file here and I will take a look and see if there may be a problem there.

Tim

avatar image Streliteela Sep 19 '16 at 09:00 AM

So so so sorry for late reply.

info.txt is attached. Is it installed in wrong path?! D:*Program Files (x86)*\Microsoft Visual Studio 14.0\Common7\Tools 的目录

link text

info.txt (7.9 kB)
avatar image Tim C ♦♦ STAFF Sep 22 '16 at 09:25 PM

The information in that file looks like it is fine. I am trying to find some additional information that may provide some clue to what is causing this issue for you.

Tim

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question