x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Source control SVN login

Hi,

I have setup source control with SVN to run on my local network, both the repo and the the UE project are on a local cloud server so both my wife and I can work on the same project at the same time.

The problem I have is that when I open the unreal project and login to source control with my username, if she then open the project she will be logged in source control with my username too, if she puts her name and then I reopen ue4 I'll be logged in with her username and so on...

Of course we could just both check that we're logged in with our own username when we open UE4 but it's easy to forget....

What am I missing here ? I tried setting the source control settings in the Editor preference but that doesn't work (it's blank when I reopen the project) how can I set this up so we're always logged in with out own username or at least to have the source control settings to pop up when we open UE4 so we can't forget about it ?

Thanks !

Product Version: UE 4.12
Tags:
more ▼

asked Aug 31 '16 at 01:32 PM in Installation & Setup

avatar image

JonathanJobin
3 2 6

avatar image Matthew J Aug 31 '16 at 02:28 PM

Hello JonathanJobin,

Am I right in assuming that the two of you are using two different computers? I know you mentioned trying the Editor Preference but, in particular, did you try turning on "Use Global Settings"? This makes it so that the Source Control login is used across the editor instead of on a per-project basis.

Also, if I remember correctly, the source control information is saved in a file somewhere so that it's populated whenever you reopen the project. I would assume that it's under the Saved folder. This file is something that shouldn't be included in the SVN repository and shouldn't be uploaded/synced. If It is, that would explain why this is happening.

I'm going to look for where this information is stored but in the meantime, can you answer/try why I mentioned?

avatar image JonathanJobin Aug 31 '16 at 04:22 PM

Hi Matthew, thanks for answering !

Yes we're using different computers. I tried using the use global setting and filled the login information, it connects me to source control fine, but if I restart UE4, global settings is still ON but the server and login information are blank so it doesn't work. There might be something wrong with permissions on our machines or something like that, I'll check that.

I've been wondering where that login information is stored in the project, and as you said this is probably why we have this issue.

Jonathan

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

So there could be a couple problems here actually. I've found where the Source Control settings are stored when Use Global Settings isn't set, so the per project settings. You can find them under the Project's directory in Saved/Config/Windows/SourceControlSettings.ini. Try opening this up in Notepad. Is it populated? Try reproducing your issue and see if this .ini changes. If it does, that means this file is being checked into your repository or updated in some way.

If this was the case, make sure that this file isn't part of your repository. If it isn't, one workaround, while we try to find out why it's getting changed, would be to set it to read-only, this would require you to log into source control every time you open the editor as it never gets to save the settings.

more ▼

answered Aug 31 '16 at 05:19 PM

avatar image JonathanJobin Sep 02 '16 at 12:48 AM

That's it ! The file is being update every time someones logs into UE4. I made sure the file isn't checked into the repo and it works now.

Thanks Matthew !

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question