x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging fails in 4.13

Hey, so I've been wrestling with some build errors and I can't figure out what's the source of all this.

Blank projects package fine and I tried moving all my content to a new project but to no avail. I'm not using any plugins but I do have some C++ code, I tried compiling without the code but it still gave me the same 8 errors.

Anyone have an idea?

link text

EDIT: Issue still persists in 4.13(new cook log attached)

Product Version: UE 4.13
Tags:
more ▼

asked Aug 31 '16 at 12:08 AM in Packaging & Deployment

avatar image

Mootjuh
304 12 8 20

avatar image Matthew J ♦♦ STAFF Aug 31 '16 at 03:06 PM

Hello Mootjuh,

It seems like there are a lot of reference problems. There are a lot of warnings in your projects mentioning missing files, missing classes that are being referenced by other assets, and so on. Can you take a look at these? While warnings themselves won't stop a packaging attempt, they could be the cause of other errors.

Also, I'm not quite sure why all of the error messages that you're suppose to be given are coming up at blank. Could you ensure that you have the Editor Symbols for Debugging installed in your build? You can check this by going to your engine installation under the Library tab of the Epic Games Launcher and selecting the "Options" selection after clicking the down arrow. If you didn't have them installed, try doing so and packaging again,

If those errors are still not visible, try uploading the log file that it mentions at this point: C:\Users****\AppData\Roaming\Unreal Engine\AutomationTool\Logs\D+Program+Files+(x86)+Epic+Games+4.12\Cook-2016.08.31-00.26.15.txt

If you can't see the AppData folder, you may need to enable being able to see hidden folders. You can find this under Control Panel > Folder Options.

avatar image Mootjuh Aug 31 '16 at 09:17 PM

Hey Matthew,

Thanks for the reply. Editor Symbols for Debugging is installed in my build. Here's the full log.link text

avatar image Mootjuh Sep 01 '16 at 10:30 PM

I've also tried upgrading to 4.13 to see if it fixed it because it seems the errors are coming from UE4's source(although empty projects work)

Here's the new log:

link text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

There seem to be quite a few handled errors by the engine. These don't cause immediate crashes but will cause issues and most likely cause the packaging to fail. Here are some examples.

 Ensure condition failed: !AttachmentRules.bWeldSimulatedBodies [File:D:\Build\++UE4+Release-4.13+Compile\Sync\Engine\Source\Runtime\Engine\Private\Components\SceneComponent.cpp] [Line: 1481]
 [2016.09.01-22.11.00:296][  0]LogOutputDevice:Error: AttachToComponent when called from a constructor cannot weld simulated bodies. Consider calling SetupAttachment directly instead.

 Ensure condition failed: this->IsBound() [File:d:\program files (x86)\epic games\4.13\engine\source\runtime\core\public\delegates\DelegateSignatureImpl.inl] [Line: 1042]
 [2016.09.01-22.11.04:627][  0]LogOutputDevice:Error: Unable to bind delegate to 'OnBeginOverlap' (function might not be marked as a UFUNCTION)

There are some load errors too that may denote that an asset that is being referenced has been deleted or moved. You may want to check to see if these files exist.

 LoadErrors: Info Failed to load /Game/Assets/Weapons/Pistol/PlasmaPistol/Art/Particles/sparks.sparks

There are multiple instances of these, so using Ctrl+F with the word "Error" would be very useful.

more ▼

answered Sep 02 '16 at 03:40 PM

avatar image

Matthew J ♦♦ STAFF
29.2k 525 85 401

avatar image Mootjuh Sep 03 '16 at 12:07 AM

The load errors I've managed to fix but my main concern has indeed been the ensure condition. I could not find a way to fix it until I tried packaging the game without our C++ code once again and it worked.. Looking at the code now to fix it.

avatar image Matthew J ♦♦ STAFF Sep 16 '16 at 05:37 PM

Hello Mootjuh. Have you had any luck fixing your issue?

avatar image Mootjuh Sep 21 '16 at 09:07 PM

Hi, yes in the end it was just our C++ code that was broken which caused the error. I didn't realise it at first but it's all good!

avatar image j0s3m4 Apr 21 '17 at 09:40 AM

Hey there! How did you fix this problem?

Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question