x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UnrealBuildTool failed due to IOException error.

When packaging my project, IOException error was occurred.

I am using UE 4.12.5. I tried to remove temporary folders, but failed. My custom UE 4.12.5 and original UE 4.12.5 are same.

I am using MS Windows 10, MS Visual Studio 2015.

Please help me.

These error logs are.

UnrealBuildTool: ====8/31/2016 11:46:51 AM====PREPARING TO MAKE APK=============================================================== ==
UnrealBuildTool: UnrealBuildTool Exception: System.IO.IOException: Cannot create a file when that file already exists.
UnrealBuildTool:
UnrealBuildTool: at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
UnrealBuildTool: at System.IO.File.InternalMove(String sourceFileName, String destFileName, Boolean checkHost)
UnrealBuildTool: at UnrealBuildTool.UEDeployAndroid.MakeApk(AndroidToolChain ToolChain, String ProjectName, String ProjectDirec tory, String OutputPath, String EngineDirectory, Boolean bForDistribution, String CookFlavor, Boolean bMakeSeparateApks, Boolean b IncrementalPackage, Boolean bDisallowPackagingDataInApk)
UnrealBuildTool: at UnrealBuildTool.UEDeployAndroid.PrepTargetForDeployment(UEBuildTarget InTarget)
UnrealBuildTool: at UnrealBuildTool.UnrealBuildTool.DoPostStartupStuffThatCanAccessConfigs(String[] Arguments)
CommandUtils.Run: Run: Took 0.9532009s to run UnrealBuildTool.exe, ExitCode=5
Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Command failed (Result:5): C:\P rogram Files (x86)\Epic Games\4.12\Engine\Binaries\DotNET\UnrealBuildTool.exe XXXX Android DebugGame -prepfordeploy -project=" XXXX.uproject" -NoHotReloadFromIDE -ignorejunk. See logfile for details: 'UnrealBuildTool-2016.08.31-11.46. 50.txt'
at AutomationTool.CommandUtils.RunAndLog(String App, String CommandLine, String Logfile, Int32 MaxSuccessCode, String Input, ER unOptions Options, Dictionary`2 EnvVars)
at AutomationTool.CommandUtils.RunUBT(CommandEnvironment Env, String UBTExecutable, String CommandLine, String LogName, Diction ary`2 EnvVars)
at AndroidPlatform.PostBuildTarget(UE4Build Build, FileReference UProjectPath, String TargetName, String Config)
at AutomationTool.UE4Build.BuildWithUBT(String TargetName, UnrealTargetPlatform TargetPlatform, String Config, FileReference Up rojectPath, Boolean ForceMonolithic, Boolean ForceNonUnity, Boolean ForceDebugInfo, Boolean ForceFlushMac, Boolean DisableXGE, Str ing InAddArgs, Boolean ForceUnity, Dictionary`2 EnvVars)
at AutomationTool.UE4Build.Build(BuildAgenda Agenda, Nullable`1 InDeleteBuildProducts, Boolean InUpdateVersionFiles, Boolean In ForceNoXGE, Boolean InUseParallelExecutor, Boolean InForceNonUnity, Boolean InForceUnity, Boolean InShowProgress, Dictionary`2 Pla tformEnvVars, Nullable`1 InChangelistNumberOverride, Dictionary`2 InTargetToManifest)
at Project.Build(BuildCommand Command, ProjectParams Params, Int32 WorkingCL, ProjectBuildTargets TargetMask)
at BuildCookRun.DoBuildCookRun(ProjectParams Params)
at AutomationTool.BuildCommand.Execute()
at AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)
at AutomationTool.Automation.Process(String[] CommandLine)
at AutomationTool.Program.MainProc(Object Param)
at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
at AutomationTool.Program.Main()
Program.Main: AutomationTool exiting with ExitCode=5 (5)
Domain_ProcessExit
copying UAT log files...
BUILD FAILED

Product Version: UE 4.12
Tags:
more ▼

asked Aug 31 '16 at 03:29 AM in Packaging & Deployment

avatar image

Lakshimi
3 3 5

avatar image Steve Hardister ♦♦ STAFF Aug 31 '16 at 04:54 PM

Hi Lakshimi,

I found a couple of similar issues that were resolved by clearing the AppData-Temp folder located:

C:\Users\\AppData\local\Temp folder

Please try this and let us know if it does not resolve the issue.

Thanks,

Steve H.

avatar image Lakshimi Sep 02 '16 at 06:41 AM

Thanks, but removing temporary files was no effect to me.

avatar image Steve Hardister ♦♦ STAFF Sep 02 '16 at 04:41 PM

Please perform these troubleshooting steps:

  1. Create a new blank C++ Project; Third Person Template

  2. Make sure this (and original project) are named with less than 20 Characters and use no special characters

  3. Package to a folder on the desktop (set this in Project Settings>Packaging)

  4. Start with a blank output log and cut and paste entire results into a text document and link results here.

  5. If blank project is successful, try again with your project, following the naming conventions in step #2

  6. If it fails, supply the entire contents of Output Log as in step #4

avatar image Lakshimi Sep 13 '16 at 08:40 AM

Thanks, I want to know what occurs this problem.

avatar image Steve Hardister ♦♦ STAFF Sep 06 '16 at 02:50 PM

Hi Lakshimi,

Since we have not heard back from you in a while we are marking this post "resolved" for tracking purposes. However, if you are still receiving this packaging error, please respond with the requested information above and we will continue to investigate.

Thanks,

Steve H.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I solved this problem recently... If proguard-project.backup is already exist, this error occurs.

more ▼

answered Sep 13 '16 at 08:38 AM

avatar image

Lakshimi
3 3 5

avatar image Lakshimi Sep 13 '16 at 08:41 AM

I solved this problem, few days ago. I modified my own engine source, if proguard-project.backup file is already exist, remove it and move file.

avatar image Steve Hardister ♦♦ STAFF Sep 13 '16 at 01:50 PM

Thanks for posting your solution.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question