x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Lighting build suddenly doesn't need applying?

I'm happily testing the lighting on my scene and and suddenly it doesn't seem to need to apply the lightmaps anymore.

I watch it state 'Lighting build complete' after encoding the textures, but then nothing.

It's not normal to not have to apply them right? Up until now I've always had to apply them after the build was complete. The lightmaps seem alright but I'm not sure, as I don't know what's wrong with it. Is it possible that it's applying the lightmaps itself? I've never had that before and it doesn't sound right.

Product Version: UE 4.12
Tags:
more ▼

asked Aug 31 '16 at 11:11 PM in Rendering

avatar image

achalmers
40 3 8 14

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi achalmers,

The lighting build has always applied itself after it completes, unless you are in the middle of adjusting, in PIE/Simulate mode, etc in which case you will see a box pop up in the bottom right asking for you to confirm applying the light build.

If you prefer to always have this option to apply it yourself after the build has finished you can go to Window > Editor Preferences > Level Editor > Miscellaneous and disable the option for Apply Lighting Automatically.

I hope this helps.

Tim

more ▼

answered Sep 01 '16 at 11:18 AM

avatar image

Tim Hobson ♦♦ STAFF
49k 886 99 875

avatar image achalmers Sep 01 '16 at 01:26 PM

I just realised this a few seconds before I read your reply. Thanks for taking the time to respond though Tim!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question