x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Alembic UV

Hi Guys,

I export Alembic Caches out of Maya and other 3rd party problems such as Max with UV's enabled. I verify the UV's are intact by opening that same exported file again in Maya or Max etc and its fine.

The issue I am having is when I import that same alembic file into Unreal the UV's seems to be messed up. First I thought maybe it was flipped or rotated but that does not seem to be the case. So basically my textures aren't correctly showing.

I am just wondering if this is a minor teething issue as its experimental and whether anyone else has this issue.

Thanks Guys

Appreciate the time.

Aaron

Product Version: UE 4.13 Preview
Tags:
more ▼

asked Sep 01 '16 at 09:22 AM in Using UE4

avatar image

TestPhase
1 1 1 1

avatar image EGJurre STAFF Sep 02 '16 at 11:48 AM

Hi Aaron,

Can you elaborate on 'incorrect UV's' and maybe attached the cache you are importing so I can take a look. Also which type are you importing the cache as?

Cheers,

Jurre

avatar image TestPhase Sep 02 '16 at 12:49 PM

Hey Jurre,

Thanks for getting back to me, I have attached an image with roughly what is going on, Its like its inverted (Flipped) the geo and UV's, so when I flip the UV's in Maya thinking that will fix the problem, it doesn't because upon importing an alembic Unreal seems to flip whatever is imported.

I am exporting the cache from Maya alembic.1.0 into unreal as static and have done the test with experimental. The animation is sweet, just this UV issue is a major issue.

Thanks

Aaron

maya_unreal.jpg (64.4 kB)
avatar image TestPhase Sep 02 '16 at 12:50 PM

link to the cache.

https://we.tl/p86phygcrL

avatar image marc_418 Sep 02 '16 at 06:35 PM

For now as a workaround to the bugs, you can rotate the object -90 deg in X, set -1 on the Z scale. For the uvw, make sure to use a texcoord node in your shader and input -1 value on the V.

You might have to manually set the bounds in your asset for it to draw properly.

avatar image TestPhase Sep 09 '16 at 02:16 PM

Thanks Marc

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question