x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

4.13 VR Rendering, No AA.

Hey guys,

Seems like 4.13 is causing all sorts of havoc with my current project. (Which is a shame, considering the numerous improvements 4.13 has on offer.)

Basically, my problem is this: The rendering has completely broken when switching between 4.12 and 4.13.

For reference, I'm currently working on this project: http://dreamdesk.io

Due to the nature of the project, I need to be able to view the textures we're creating at full resolution, without distortion no matter which angle or distance they're being viewed at.

Anyways, so after a bunch of tinkering I had found a batch of settings that made the textures nice, crisp and legible within 4.12.

To my dismay after I switched to 4.13, the changes to the VR Rendering have made my textures jaggy and illegible when viewed within the HMD. I tried playing with a bunch of the rendering settings all over again within 4.13 and it seems that I cannot find the proper combination to achieve what I'm looking for.

Straight lines are jaggy. Words are distorted at a distance or angle.

So, I figured I should reach out again to the wonderful devs over at Epic who may be able to shed some light on what I can do to fix this.

Unfortunately, I cannot provide screenshots as the mirror window displays fine though within the HMD things are just a mess.

As a reference, here's roughly what I've got going on in 4.12:

     GEngine->Exec(GetWorld(), TEXT("hmd sp 300"));
     GEngine->Exec(GetWorld(), TEXT("r.DefaultFeature.Bloom False"));
     GEngine->Exec(GetWorld(), TEXT("r.DefaultFeature.AntiAliasing 0"));
     GEngine->Exec(GetWorld(), TEXT("r.DefaultFeature.AmbientOcclusion False"));
     GEngine->Exec(GetWorld(), TEXT("r.DefaultFeature.AutoExposure False"));
     GEngine->Exec(GetWorld(), TEXT("r.DefaultFeature.MotionBlur False"));
     GEngine->Exec(GetWorld(), TEXT("r.ReflectionCaptureResolution 64"));
     GEngine->Exec(GetWorld(), TEXT("r.DefaultFeature.AmbientOcclusionStaticFraction False"));
     GEngine->Exec(GetWorld(), TEXT("r.EarlyZPass 1"));
     GEngine->Exec(GetWorld(), TEXT("r.EarlyZPassMovable True"));
     GEngine->Exec(GetWorld(), TEXT("r.BasePassOutputsVelocity False"));
     GEngine->Exec(GetWorld(), TEXT("r.TextureStreaming False"));
     GEngine->Exec(GetWorld(), TEXT("r.ScreenPercentage 200"));
     GEngine->Exec(GetWorld(), TEXT("r.ViewDistanceScale 1.0"));
     GEngine->Exec(GetWorld(), TEXT("r.PostProcessAAQuality 0"));
     GEngine->Exec(GetWorld(), TEXT("r.ShadowQuality 0"));
     GEngine->Exec(GetWorld(), TEXT("r.TextureQuality 0"));
     GEngine->Exec(GetWorld(), TEXT("r.EffectsQuality 1"));
     GEngine->Exec(GetWorld(), TEXT("sg.ResolutionQuality 25"));
     GEngine->Exec(GetWorld(), TEXT("sg.ViewDistanceQuality 0"));
     GEngine->Exec(GetWorld(), TEXT("sg.AntiAliasingQuality 0"));
     GEngine->Exec(GetWorld(), TEXT("sg.PostProcessQuality 0"));
     GEngine->Exec(GetWorld(), TEXT("sg.ShadowQuality 0"));
     GEngine->Exec(GetWorld(), TEXT("sg.TextureQuality 0"));


I've been meaning to move these out to the .ini file but for now they work where they are.

Thanks for any and all help, -ozzadar

Product Version: UE 4.13 Preview
Tags:
more ▼

asked Sep 01 '16 at 03:30 PM in Rendering

avatar image

ozzadar
17 5 9 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question