x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Upgraded from 4.11 to 4.12, and project won't open

I just upgraded from 4.11 to 4.12. My old project has some blueprints that I would like to gain access too. Can't really remember how I had implemented them.

Error messages are:

[2016.09.02-08.18.55:202][ 0]LogLinux:Warning: dlopen failed: /home/zerophase/Documents/unrealprojects/Dialogues/Binaries/Linux/libUE4Editor-Dialogues-494.so: symbol _ZN6AActor20NotifyActorOnClickedEv, version UE4 not defined in file libUE4Editor-Engine.so with link time reference [2016.09.02-08.18.55:202][ 0]LogModuleManager:Warning: ModuleManager: Unable to load module '/home/zerophase/Documents/unrealprojects/Dialogues/Binaries/Linux/libUE4Editor-Dialogues-494.so' because the file couldn't be loaded by the OS.

I tried removing that file, and just ended up getting the same error, on libUE4Editor-Dialogues.so.

What are my options for upgrading the project?

Product Version: UE 4.12
Tags:
more ▼

asked Sep 02 '16 at 08:37 AM in Linux

avatar image

zerophase
88 3 9 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Remove all old .so files, especially ones that have numbers in them (like -494.so in your example) - those were hot reloaded. Preferably, do not reuse the same directory for a new engine version.

more ▼

answered Sep 02 '16 at 02:40 PM

avatar image

RCL STAFF
2.1k 59 6 85

avatar image zerophase Sep 02 '16 at 03:22 PM

Ok, I'll give that a try. I'm guessing Linux doesn't have all the features of Windows yet for upgrading projects?

avatar image RCL STAFF Sep 02 '16 at 03:26 PM

Yes and no. On Windows you can also run into problems due to stale DLL files lying around.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question