x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

4.13 absolutely DESTROYED sections of my level.

I have created an apartment building in unreal... and some of the rooms are duplicates... so usually i would just attach them or group them... dont remember which... and i would duplicate and rotate it into position. Sometimes even scale it in -1 to be a mirrored version.

Just converted my project to 4.13.... and some parts of my level are just all over the place... props all over props not visible.. positions shifted in that room.. its just weird stuff.. totally destroyed... see the screen shots with correct vs 4.13 destroyed. alt text

alt text

Product Version: UE 4.13
Tags:
room_correct.jpg (690.7 kB)
room_messedup.jpg (671.3 kB)
more ▼

asked Sep 02 '16 at 11:50 AM in Bug Reports

avatar image

kurylo3d
464 46 82 108

avatar image Adam Davis STAFF Sep 02 '16 at 01:49 PM

Hi kurylo3d,

  • Does this occur in a clean, blank project with no additional content or is this limited to one project?

  • What steps can I take to reproduce this on my end?

  • Are these BSPs or Static Meshes?

  • Are any of the actors in sublevels? If so, are the sublevels hidden?

avatar image kurylo3d Sep 02 '16 at 03:03 PM

all static meshes. They are all in 1 sublevel.. though others exist the problem does not extend to them.

They are all static meshes.

My assumption is what i wrote in the top of this.. the meshes that have hte problems were created through the means of me creating 1 apartment unit modularly.. Then i beleive i may have attached all peices onto 1 of the static meshes in unreal so they would move and scale together. (grouping i dont think scales correctly.) So then i duplicated scaled it in negative 1 rotated the entire apartment unit into position.. then detached it all... works fine ... But when i downloaded unreal 4.13 i opened a copy of the project in unreal 4.13 and when i viewed the level.. that duplicated and scaled room static mesh modular peices were all over the place...

I couldnt tell u if it happens in a clean or blank project or not.

avatar image Adam Davis STAFF Sep 02 '16 at 05:26 PM

Do you have any steps I can take to reproduce this on my end?

avatar image kurylo3d Sep 02 '16 at 05:42 PM

Only steps i can think of is what my assumption was... from attaching objects to another object, duplicating. scaling that object -1 so the rest scale with it, detaching it... saving... and i guess then opening the project in 4.13 as a copy... start with 4.12.

avatar image Adam Davis STAFF Sep 02 '16 at 05:54 PM

Unfortunately I was unable to reproduce this with the steps provided. Do you have a sample project the error is occurring in I can take a look at?

avatar image kurylo3d Sep 02 '16 at 06:05 PM

unfortunately its huge...file size wise... i dont know if creating a sample would work.. but i dont even know how i can send you a project like that... how do u send only used static meshes and textures?

You also try rotating and scaling both :P and grouping and ungrouping ... it only happens in teh mirrored copy room... so its definently having to do with that....

avatar image kurylo3d Sep 03 '16 at 11:22 AM

maybe try doing rotation of attached or grouped stuff instead of scale... with the attached stuff... i just realized the room thats broken isnt even scaled.. its just rotated into position...

Another room has -1x and -1 y .... but that room is fine...

dont remember if hte third room is a duplicate of that room back to 1 x 1 y... of if it was just rotated from the original room that was never scaled... its just odd that this is happening at all as an issue.

avatar image kurylo3d Sep 04 '16 at 01:29 PM

The plot thickens.. I actually found something rather interesting. In the new 4.13 version... the level is using the whole sub level set up with multiple levels in the same directory. If i open the apartment building level alone(not as a sublevel)... the room is not messed up, but if i open the main level and go to window -> levels and load up the level that way.. the room is screwed up with things moved all over...

I have no idea why that makes a difference , but it does.. it makes no sense.

Also i am unable to replicate it outside my level... no idea what to do to make this happen, i just know now that the sub level set up causes the problem where the map loaded alone the problem does not exist... what can i do?

avatar image kurylo3d Sep 04 '16 at 07:20 PM

I tried copy and pasting the level into another directory where it loaded fine, but then i created a new "main level" that had world composition on and loaded that level. I used then went to the Window -> Levels and loaded the problem level and the issue was still there.. So its not hte world composition level thats the problem... its the combo of any main world composition level used to load this apartment level. Wtf? its just lots of stuff is rotated what seems to be 180 degrees in that room.

avatar image kurylo3d Sep 04 '16 at 07:29 PM

Without using world composition.....

I literally tried to copy and paste the entire level into a new level for testing purposes with odd results... some of the walls in that room that are rotated... at -90... (correct would be 90..) Cannot be rotated back to 90. If i enter 90 as a value... it literally snaps itself back to -90 automatically. wtf!?!?!?!?

UPDATE I loaded up that copy paste version of the apartment building as a new level again only to realize if i enter 90 degrees as z rotate for any static mesh in that room... it snaps it to -89. so i cant rotate any mesh that is a problem mesh to 90 degrees... what on earth is going on with this engine and this level.

avatar image Adam Davis STAFF Sep 07 '16 at 02:41 PM

Hi kurylo3d,

I've tried the above suggestions and have not been able to reproduce the error on my end. Do you have any other steps or a sample project I can look at to recreate this error on my end?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi kurylo3d,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

more ▼

answered Sep 12 '16 at 02:13 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question