x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.13.0] AI MoveToLocation no longer working

Hi all,

Just updated my project to 4.13.0 to experiment with the new features. Whilst the game is intact and no major issues are evident, the MoveToLocation call no longer functions. The result in the code is "Success", but the AI characters are no longer working correctly and are just standing still. The navigation mesh is working as intended and generating during runtime and all settings on the CharacterMovement component seem OK.

Are there any new settings I should be aware of? The changelog doesn't have much regarding navigation when compared to everything else.

Thanks,

Jamie

Product Version: UE 4.13
Tags:
more ▼

asked Sep 02 '16 at 05:32 PM in C++ Programming

avatar image

jamiewhitephd
48 6 13 17

avatar image oO Sykes Oo Sep 03 '16 at 03:43 AM

hey I just have something to add hopefully its related , I've noticed my ai move to node in one of my btt tasks now results in a super slow walk ( almost like its colliding with something ) since updating to 4.13

avatar image BrUnO XaVIeR Sep 06 '16 at 04:42 AM

This node is a constant source of issues for many times the engine is updated to new version. I've seen it broken/fixed many many times already...

avatar image Kausemus Sep 07 '16 at 02:17 PM

Same happened to me. "AI Move To" takes the sequence to "Fail" each time. In last patch it worked fine.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I managed to solve my problem a while ago so I thought I would post an answer in case people are still having issues with this. Prior to 4.13, you could tell the AI to move to the same location every frame and it will work fine. However, now, you need to only call it once, otherwise the movement functionality in the AI classes will reset each time - hence my enemies standing still.

I added some logic that only called the AI move function if the distance between the player's location and the AI's player "known" location is greater than a set threshold.

more ▼

answered Dec 31 '16 at 05:49 PM

avatar image

jamiewhitephd
48 6 13 17

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

same here, but happen in blueprints.

more ▼

answered Sep 09 '16 at 11:33 AM

avatar image

GAME3D
86 3 5 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question