x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[SOLVED] Can't include local header file to plugin PCH.h

I have both ForestGeneratorPrivatePCH.h and ForestEdMode.h in Private folder of my plugin, but trying to add inside ForestGeneratorPrivatePCH.h this line

 #include "ForestEdMode.h"

results in

Severity Code Description Project File Line Suppression State Error C1083 Cannot open include file: 'ForestEdMode.h': No such file or directory MyProject c:\users\mvlabat\documents\unreal projects\myproject\plugins\forestgenerator\source\forestgenerator\private\ForestGeneratorPrivatePCH.h 8

Moving ForestEdMode.h to Public folder doesn't help. I've tried recreating the plugin and the project several times - all in vain.

Would be glad for any help. Thanks in advance!

Product Version: UE 4.12
Tags:
more ▼

asked Sep 02 '16 at 09:30 PM in C++ Programming

avatar image

mvlabat
28 5 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

The problem was because of the header file wasn't actually in the same folder. It was only displayed in Visual Studio so, because I used adding existing file. I supposed this feature copies chosen files into selected folder, my bad.

more ▼

answered Sep 02 '16 at 10:43 PM

avatar image

mvlabat
28 5 4 8

avatar image DisplaySweet Sep 21 '17 at 03:28 AM

... dude, can you explain more details. I have exact same issue on making this functional: https://answers.unrealengine.com/questions/194148/mounting-pak-files-at-runtime-1.html

it doesn't accept my #include "AssetStreamer.h" in VS.

avatar image mvlabat Sep 21 '17 at 08:17 AM

Just make sure, that your "AssetStreamer.h" is the same physical folder as it's shown in VS. (Do it with windows explorer, for example.) If it's not here, move it where it has to be, after that try to run GenerateProjectFiles.bat in your project folder - that'll fix your files tree in VS.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question