x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Editor] Menus broken as of latest Windows 10 insider update

This issue is encountered on 4.12, 4.13, and Epic's launcher too as soon as we updated to the latest Windows insider build.

As of the latest Windows 10 insider update, the menus are buggy/broken in both Unreal Engine versions I've tried, I'm not sure what happened but I bet Microsoft did something, they always break something, I've reported the issue but only a few 2 other people had it as I suppose not many UE users are on insider builds, so if this keeps up the issue will make its way into an official update and Unreal Engine will be officially broken for all WIndows 10 users.

Is there any possibility to find a solution to this?

Windows 10 Version: 1607 Build: 14915.1000

Product Version: UE 4.13
Tags:
more ▼

asked Sep 03 '16 at 10:18 AM in Bug Reports

avatar image

JacobMrox
55 1 5 9

avatar image rubenst Sep 03 '16 at 03:31 PM

Same issue here, though I only tested the Master branch so far.

Hmm, guess I will try going back to latest non-insider release, if the darn thing lets me that is :D

avatar image JacobMrox Sep 03 '16 at 04:40 PM

I would downgrade to Windows 7 if Direct X 12 isn't a Windows 10 exclusive feature, wtf.

avatar image OverRated_AU Sep 16 '16 at 09:21 AM

Same bug on 14926 as well.

avatar image rubenst Sep 17 '16 at 12:01 PM

confirmed, and on 14926 something in regards to hardware virtualization is broken too (no more VirtualBox or Hyper-V :( )

avatar image RPerryStL Sep 22 '16 at 02:34 AM

The problem still persists with build 14931 (updated 9/21). I've discovered that I can sometimes get a menu to appear if I click on one of the menus then slide over the adjacent menus quickly. If I shrink the editor window it also works intermittently. I realize this isn't much help, but perhaps it could help point to a solution... Or maybe we just have to wait for MS to fix their build. Right now I'm wishing I'd got out of Insider when I had the chance.

avatar image KelDG Dec 08 '17 at 12:30 PM

Do you use a graphics tablet by any chance? I am having this issue now, what is happening is when you click windows says "oh you want to scroll" using the new obtrusive 'PEN Scroll' option. Essentialy you cant select any option in a menu that has the ability to scroll. There is no way to turn this option off, its infuriating.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

7 answers: sort voted first

Hi, I found a workaround that just now fixed it for me!

essentially I rolled back the update of 14915 to 14905 as follows:

Hit Windows-i and choose "Update & Security", from there you go to "Recovery" and start the process of "Go back to an earlier build".

Rollback Windows 10 build

During that process it will ask you to provide a reason (checkbox is enough) and it will ask you if you want to searc hfor updates INSTEAD, for that question you choose "no" and continue with the rollback.

Be careful to save all your open files, close all other programs as it will immediately reboot your computer after the final notice! :)

The rollback itself took less than 5 minutes for me and all the menus in UE4 are working again. :)

As a side note: in Win10 redstone 2 insider preview build 14905.1000 the windows context menus are broken. You can use Windows key + X to get access to the sleep and reboot functions and check back later.

I also contacted Microsoft Support about this issue and they assured me the broken incompatibilities with UE4 (among unnamed others) is known to them and a fix is already in the making.

Have fun and stay unreal! :)

win10_rollback.jpg (106.0 kB)
more ▼

answered Sep 03 '16 at 05:34 PM

avatar image

rubenst
91 9 9 16

avatar image JacobMrox Sep 03 '16 at 06:11 PM

Unfortunately this is the only solution, and I do hope it is fixed in the next Windows 10 / redstone build. I cannot go back the an older build now since I keep using disk cleanup to remove unwanted data and junk, so I have to wait for a new build.

avatar image rubenst Sep 03 '16 at 07:33 PM

Yes, that is right...if you cleaned up the older windows installation this step becomes as involved as re-installing #Everything :/

But if you happen to have the older windows installations still on site, then its as easy as it gets. I honestly expected the thing to take literally hours.

One thing I also wanted to mention was that I had to recompile both my master branch and project. For others using the binary release a validation of engine and project files through the launcher may be advisable.

avatar image JacobMrox Sep 03 '16 at 08:49 PM

Well I'm screwed right now then, I should probably leave insider next time, any estimation on when the next build comes out at least?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

High Contrast Theme

When I encountered this issue here is the solution I figured out, and this was the only thing I had to do:

Overview: Use one of Windows10's high contrast themes

How To:

  • Do a search in windows start menu for "high contrast"

  • Select one of the high contrast themes from the drop down or tiled list depending on your OS version. You can customize these themes!

  • Click Apply

Now you will find all of the drop downs in UE4 that were either slow or not appearing at all will now work perfectly again.

Rama

more ▼

answered May 09 '17 at 02:07 AM

avatar image

Rama
10.6k 446 346 1088

avatar image momoSuper May 16 '17 at 02:46 AM

this work for me

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I'm having this same problem, I'm on insider build 14915. Can't click the settings gear icon in the epic launcher. Can't click various icons inside the project picker. Can't click any menus (file, edit, etc...) in the ue editor.

more ▼

answered Sep 04 '16 at 09:09 AM

avatar image

Strangeloopr
16 4

avatar image JacobMrox Sep 04 '16 at 11:53 AM

The build is really a mess, as if I needed more pressure, I will stay on the next RTM build when it comes out and leave the insider program. I've no idea how they screwed up menus, given the fact they're a computer giant, their insider builds shouldn't have such silly issues, I expect new features to get broken not old ones, oh well.

Edit: I just reinstalled Windows and I won't use insider builds ever on a stable PC again. Stability is top priority.

avatar image zismylove Sep 22 '16 at 08:30 AM

oh.when i start my computer ,the system tell me i have to update my system,last time is Oct /1 ,,if not ,the system will reboot every 3 hours,why the mircosoft don't to do something?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Windows just forced an update on me. I rolled back from the build which originally caused the problem, then held back on subsequent ones, but windows told me my build would expire - then it just crashed everything out and did the update!

This is pretty outrageous I think. On the other side of this - for an easy life - I'd love it if Epic had a quick fix for this perhaps in the editor settings or something?

At some point there won't be anything to roll back to!

more ▼

answered Sep 22 '16 at 05:39 PM

avatar image

Dannington
113 5 9 16

avatar image rubenst Oct 05 '16 at 09:35 PM

Recently Win10 RS2 14931 was pushed to the "slow ring" -> meaning more people will be experiencing the same issue :(

avatar image Koraken Oct 21 '16 at 07:07 PM

Yep, currently in the slow ring on that build and I'm still having the same issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

In build 14965.rs_prerelease.161104-1700 The menus seem to be working again. The only thing is that here seems to be a delay up to 10 seconds from the time the button is clicked to when the menu shows up. Subsequent displays of the menu seem to work better but that first load is a killer.

more ▼

answered Nov 14 '16 at 02:23 PM

avatar image

cajun_code
36 2 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

If you click say, settings, and then move the Unreal 4 engine window, you'll see the menu is painting behind the window for Unreal 4. (at least my behavior, on 14971)

more ▼

answered Nov 26 '16 at 03:55 PM

avatar image

jeffstokes72
6 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

OK think I have solved it...

This issue isn't just on Unreal its across all apps on my machine.. Basically you need to remove context menus (for NVIDIA and in my case Intel as well)

**http://www.intowindows.com/fix-slow-desktop-right-click-in-windows-10/**

(try this first)

if this doenst fix it then using CCLEANER - disable all the context menus via Tools options

Hope that helps some of you out there...

Dunk !!!

more ▼

answered Jul 17 '17 at 12:46 AM

avatar image

DunkenKBliths
226 3 100 16

avatar image OverRated_AU Jul 17 '17 at 05:38 AM

Just update the engine the problem is fixed in later editors versions.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question