x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Light Building Stuck at 0%

Hi,

Basically, I'm having trouble getting my lighting to build at all. It starts at 0% and never moves from there. I have tried building in an empty scene as well as the default setup.

I've searched for similar questions and have yet to get any working answers. I've checked that port 8008 and 8009 are not blocked, and made sure that my firewall/antivirus wasn't getting in the way of Unreal and Swarm communicating.

The swarm log gives me this error:

15:15:28: LogSwarmInterface:Error: [TryOpenConnection] Waiting for the agent to start up ... 15:15:28: [TryOpenConnection] Waiting for the agent to start up ... 15:15:28: LogSwarmInterface:Error: System.Net.Sockets.SocketException (0x80004005): An attempt was made to access a socket in a way forbidden by its access permissions 127.0.0.1:8008

Has any encountered this problem and found a solution? I have tried this with UE4.13, 4.12 and 4.8 but to no avail.

Thanks, Ben

Product Version: UE 4.13
Tags:
more ▼

asked Sep 06 '16 at 01:22 PM in Using UE4

avatar image

Ben_M
3 1 3 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Ben,

This information on our Wiki for Swarm Agent should help you identify what programs/processes are using the ports for 8008 and 8009: https://wiki.unrealengine.com/Swarm_Agent_Troubleshooting#Swarm_Log:_System.Net.Socket_Error.2FSwarm_Agent.2FCoordinator_Port_Used_By_Another_Process

Unfortunately, I'm not super familiar with reassigning ports or helping with that side of things with Windows, so this may require some googling on your part to find a solution.

In the past when some have given up on trying to track down or change the port assignments they've just reinstalled Windows without dealing with the problem which immediately solved it since the ports were no longer in use by the other processes.

Anyway, I hope this helps at least identify what is being used by those ports.

Tim

more ▼

answered Sep 09 '16 at 07:01 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

avatar image Ben_M Sep 11 '16 at 10:50 PM

In the end, there was another program blocking the port. Thanks a lot for the info!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question