x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Not a single event firing in the playercontroller blueprint

Is it possible that the installation of the version 4.13 went wrong and now in every project that I start events in the playercontroller blueprint doesn’t fire? After the installation of version 4.13 I tried to create projects in 4.12.5 and the problem remains. But if I launch the Project created before install of the new version everything works fine and I can create events in the playercontroller BP that are working.

Product Version: UE 4.13
Tags:
more ▼

asked Sep 05 '16 at 07:04 PM in Blueprint Scripting

avatar image

Maxwell
1 1 2 1

avatar image ImVawx ♦♦ STAFF Sep 05 '16 at 07:56 PM

Hey Maxwell,

I am not experiencing the same issue. Here is what I have setup:

alt text

If you can, please post again with more information regarding how you are calling your PlayerController events.

You can also check the following:

  • Is your PlayerController class set in the GameMode as PlayerControllerClass?

  • Are you correctly casting any reference of PlayerController into your PlayerController class?

  • Is there anything that might prevent your PlayerController class from firing an event, such as a condition?

avatar image Maxwell Sep 05 '16 at 10:35 PM

My steps are: 1) Create a FPS 2) Create a Player Controller BP 3) Assign it to Player Controller Class 4) In the Player Controller BP I connect BeginPlay Event with PlaySound2D Node 5) Assign a sound file 6) Launch the game -> no sound

If I cut and paste this two nodes in Player Character BP evrything works fine: sound id playing at GameStart. I tried in Player Controller BP button input events, result is the same -> the BP print shows no firing signals during gameplay.

avatar image ImVawx ♦♦ STAFF Sep 06 '16 at 03:23 PM

Hey Maxwell,

I am still not seeing any issue. This is what I have:

alt text

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question