x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

3D Scene Capture Cube blurry on movement

Hi,

I'm currently using a Scene Capture Cube to render a scene on a plane, but the texture applied is always blurry when the player/camera is in movement. I tried every compression settings on the RenderTarget and pretty much every post process settings on the camera, and so far nothing removes the blur.

Has anyone found a way to fix this?

Expected results: alt text

Result when close to the plane and moving: alt text

Reference video: https://ppotn40-hotmail.tinytake.com/sf/OTc1Mzc3XzQwNjY5OTI

Product Version: UE 4.13
Tags:
expected.png (405.8 kB)
result.png (306.6 kB)
more ▼

asked Sep 06 '16 at 07:12 PM in Rendering

avatar image

CyanBalloon
70 7 12 16

avatar image kingcrimson Sep 17 '16 at 01:05 AM

Sorry for bothering you, but if you are doing this in C++, do you mind taking a look at my question here https://answers.unrealengine.com/questions/489577/c-scene-capture.html?

avatar image CyanBalloon Sep 17 '16 at 02:59 AM

It's no bother really, but I'll have to say I can't help you there. We're talking 3D scene capture here, and not in C++, sorry =(.

Cheers!

avatar image HitEmUp Mar 16 '17 at 09:21 PM

Have the same problem, do you find a solution?

avatar image CyanBalloon Mar 16 '17 at 09:43 PM

Didn't find a solution so far, sorry. We simply don't use it anymore.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Turn off Motion blur from your post process effects.

more ▼

answered Apr 30 '17 at 12:59 AM

avatar image

SaitYavuz
16 4 9 9

avatar image SaitYavuz Apr 30 '17 at 02:16 AM

Also, you can turn off anti-aliasing if you still find it blurry.

Go to post process volume, misc, then select "None" on the AA method.

avatar image CyanBalloon Apr 30 '17 at 04:45 PM

We flushed the idea, but we might get back into it. Thing is, it's definitely not a good alternative to disable motion blur and/or anti-aliasing in the game. Do you mean disable these options in the 3D Scene Capture Cube's post process only, or the project in general?

avatar image SaitYavuz May 10 '17 at 01:03 PM

The reason you get the blur is because of motion blur in your level. The way you turn off the motion blur is by going to post process volume(create one if you don't have one) and go to settings, find motion blur, set the "Amount" to 0. After that, the blur will go away. The reason this happens is because motion blur uses scene depth to decide what should be blurred.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question