x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Tessellated landscape gaps

I have a problem with tessellated landscape. There are gaps visible in it as you can see from the screenshot. The tessellation mode is PN Triangles, Crack free displacement is on and adaptive tessellation is on, Max displacement is 100000.

Would really like to know if there is a fix for that.

alt text

Product Version: UE 4.13
Tags:
tessgaps.jpg (70.5 kB)
more ▼

asked Sep 08 '16 at 07:45 AM in Rendering

avatar image

Kvazimodo
31 4 8 7

avatar image Roel Sep 08 '16 at 03:59 PM

Are you using 4.13? Since it had some updates on tessellation on the landscape itself. If you are it is probably a bug where the next component in the landscape is not using tessellation, but also not accounting for the vertex offset near the edge.

avatar image Kvazimodo Sep 08 '16 at 05:24 PM

Is there a way to fix it, or do we just wait till the next update?

avatar image Kvazimodo Sep 10 '16 at 07:17 AM

Still need a solution for this bug

avatar image Deathrey Sep 10 '16 at 08:47 AM

Maybe you just using too high displacement values?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Just tested it, I was incorrect about the components part. The tessellation does correctly fade out based on the LOD distance, and with your setup it is also broken on my PC.

I did however get a setup to work: -Set your Tessellation Mode to PN triangles if you want smoothed tessellation. -Turn off(!) crack free displacement. For some reason this does not work correctly with landscapes, I have no idea why. -You can probably turn off adaptive tessellation since it is already addaptively tessellating based on the LOD distasnce, so tweak the LOD distance factor in your landscape itself.

My world displacement is just a texture using the landscape coordinates multiplied with a "Displacement Strength" scalar after which it is multiplied with the vertex normals ws node.

more ▼

answered Sep 10 '16 at 01:21 PM

avatar image

Roel
2.5k 70 43 143

avatar image Kvazimodo Sep 11 '16 at 11:15 AM

When I created my landscape, I used height map. Then added the layers so that I could use several different textures for it. I still can't get rid of the gaps. Tried your recommendations with no effect. The gaps are less visible when using Linear LodFalloff but they are still there.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Fixed the problem. It was one of the settings for the intensity of displacement that I set to negative value.

more ▼

answered Sep 12 '16 at 01:09 PM

avatar image

Kvazimodo
31 4 8 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question