Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.13 Cooking/Packaging Fails Error: begin: stack for UAT

Been trying to work out why my project won't cook or package. Looking at the logs no individual BP or asset seems to give an error as far as I can tell.

First error I see is: LogWindows:Error: begin: stack for UAT

No idea what that means. Logs attached.

Product Version: UE 4.13
more ▼

asked Sep 08 '16 at 02:13 PM in Packaging & Deployment

avatar image

261 13 12 93

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Can confirm my game packages with no problems now! Solution was to move "create render target 2d" to begin play.

more ▼

answered Oct 01 '16 at 07:39 PM

avatar image

261 13 12 93

avatar image Samantha Sutton ♦♦ STAFF Oct 06 '16 at 09:49 PM

I'm glad you've gotten the issue resolved - thanks for posting your solution!

avatar image Gwak Seon-geun Nov 14 '18 at 02:41 AM

Big thanks. You saved the day for me!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users


This is the error found within the logs you've provided. It seems relating back to the code.

  • Did you change any of the code in your project?

  • Have you tried deleting your Intermediate and Saved folders from your project file and attempting to repackage?

  • Have you tried verifying your version of the engine?

    [2016.09.08-13.57.35:043][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:900][ 0]LogWindows:Error: === Critical error: ===

    [2016.09.08-13.57.35:045][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:900][ 0]LogWindows:Error:

    [2016.09.08-13.57.35:047][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:900][ 0]LogWindows:Error: Fatal error: [File:D:\Build\++UE4+Release-4.13+Compile\Sync\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp] [Line: 721]

    [2016.09.08-13.57.35:048][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:901][ 0]LogWindows:Error: Rendering thread exception:

    [2016.09.08-13.57.35:049][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:901][ 0]LogWindows:Error: Fatal error!

    [2016.09.08-13.57.35:050][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:901][ 0]LogWindows:Error:

    [2016.09.08-13.57.35:050][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:901][ 0]LogWindows:Error: Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x00000078

    [2016.09.08-13.57.35:051][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:901][ 0]LogWindows:Error:

    [2016.09.08-13.57.35:051][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:901][ 0]LogWindows:Error: UE4Editor-Engine.dll!TGraphTask<`UTextureRenderTarget2D::UpdateResourceImmediate'::`2'::EURCMacro_UpdateResourceImmediate>::ExecuteTask() [d:\build++ue4+release-4.13+compile\sync\engine\source\runtime\core\public\async\taskgraphinterfaces.h:868]

    [2016.09.08-13.57.35:052][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:902][ 0]LogWindows:Error: UE4Editor-Core.dll!FNamedTaskThread::ProcessTasksNamedThread() [d:\build++ue4+release-4.13+compile\sync\engine\source\runtime\core\private\async\taskgraph.cpp:932]

    [2016.09.08-13.57.35:052][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:902][ 0]LogWindows:Error: UE4Editor-Core.dll!FNamedTaskThread::ProcessTasksUntilQuit() [d:\build++ue4+release-4.13+compile\sync\engine\source\runtime\core\private\async\taskgraph.cpp:679]

    [2016.09.08-13.57.35:053][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:902][ 0]LogWindows:Error: UE4Editor-RenderCore.dll!RenderingThreadMain() [d:\build++ue4+release-4.13+compile\sync\engine\source\runtime\rendercore\private\renderingthread.cpp:319]

    [2016.09.08-13.57.35:053][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:903][ 0]LogWindows:Error: UE4Editor-RenderCore.dll!FRenderingThread::Run() [d:\build++ue4+release-4.13+compile\sync\engine\source\runtime\rendercore\private\renderingthread.cpp:440]

    [2016.09.08-13.57.35:053][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:903][ 0]LogWindows:Error: UE4Editor-Core.dll!FRunnableThreadWin::Run() [d:\build++ue4+release-4.13+compile\sync\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:74]

    [2016.09.08-13.57.35:053][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:903][ 0]LogWindows:Error: UE4Editor-Core.dll!FRunnableThreadWin::GuardedRun() [d:\build++ue4+release-4.13+compile\sync\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:31]

    [2016.09.08-13.57.35:054][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:904][ 0]LogWindows:Error: KERNEL32.DLL

    [2016.09.08-13.57.35:054][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:904][ 0]LogWindows:Error: ntdll.dll

    [2016.09.08-13.57.35:055][935]UATHelper: Cooking (Windows): UE4Editor-Cmd: [2016.09.08-13.57.34:904][ 0]LogWindows:Error: ntdll.dll

more ▼

answered Sep 08 '16 at 05:53 PM

avatar image Defaultsound Sep 08 '16 at 06:15 PM
  1. I have not changed any Engine code as far as I am aware, I downloaded 4.13 through the launcher. The only thing I have got is my project running through Visual Studio Community 2015, I did update this as well today. About a month ago I did manage to package my project in 12.5 using VS. Since when attempting without it, packaging would bring up an error saying I was required to build through VS. So I tried generating Visual Studio files, open that up, build solution, then run the project through that, and then tried packaging, but still nothing.
    1. I tried deleting those folders as I saw in another question similar to this. After I did that I tried packaging again and it did not work.

    2. Just verified the version, and as well did not work.

Now I do have one plugin that I am using, https://forums.unrealengine.com/showthread.php?116782-VR-(OpenVR)-Expansion-Plugin

I believe this could break things, but I'm not too sure.


Just remembered I haven't packaged since adding this plugin, so possibly this could be the cause.


Still no idea, tried updating the plugin, tried packaging still no luck, just giving the error of line 721 in the rendering thread, which I haven't touched

avatar image Defaultsound Sep 09 '16 at 01:20 PM

Just tried reinstalling 4.13 today and I am still getting the same error. I also tried packaging a completely blank project and that did work, but I tried another project and that also did not work.

avatar image Defaultsound Sep 09 '16 at 05:34 PM

Tried adding the plugin to the blank project, still managed to package it. Been trying to break the blank project and recreate the error, but so far I haven't been able to pinpoint it to a specific thing that causes the error.

avatar image Samantha Sutton ♦♦ STAFF Sep 13 '16 at 05:41 PM

So, after you uninstalled and reinstalled the editor, added the plugin back in and started creating projects, it no longer runs into the same error? If so, it sounds like there was likely a corrupted file.

avatar image Defaultsound Sep 13 '16 at 05:50 PM

Unfortunately that is not the case, I am still getting the error with my project. The only solution I can think of doing is to recreate the project again, and copy everything over and try and package it in the new project. This however could be a complex task. I haven't a clue why the error happens though.

avatar image Samantha Sutton ♦♦ STAFF Sep 19 '16 at 04:50 PM

If you remove this plugin, are you able to package? That's what we need to know. Because if you can package your project without the plugin included, then you'll need to speak with the creator of the plugin, in order to resolve the issue.

Thank you!

avatar image Defaultsound Sep 19 '16 at 04:54 PM

I did try and remove the plugin and it didn't seem to help. I tried adding the plugin to a new project to check if it was the plugin and that new project managed to package it fine. So my only option at the moment is to try and port my entire current project over to a new project and see if starting fresh helps at all.


Just tried updating the plugin, still not packaging. My only guess is that the project has legacy data from previous versions that might cause conflicts, so unless there is a way to clean it I suppose the other option is to port it over to a new project.

avatar image Samantha Sutton ♦♦ STAFF Sep 22 '16 at 05:15 PM

If deleting your Intermediate, Saved and Config files do not - migrating may be your best option. Please let me know if migrating does not work and upload any new logs so I can show them to our Developers.


avatar image Defaultsound Sep 22 '16 at 11:31 PM

Okay thank you, I'll have you get back to you another time since we are close to finishing alpha. After that I'll migrate the whole project over to a new one and let you know if it packages.

avatar image Samantha Sutton ♦♦ STAFF Sep 23 '16 at 02:54 PM

Sounds good. For now, I will mark this post as resolved. Please feel free to comment back and it'll reopen in my inbox.


avatar image Defaultsound Oct 01 '16 at 07:05 PM

So I went ahead and migrated the project today, and still no luck. So I was determined to figure out what was going on.

So I decided to start by removing all maps and just insert a blank map into my project. Sure enough, no issues packaged no problem. So I put one map back in at a time and found the first to package fine as well. Then I put the main level back in, and then errors again.

So from this I decided to try and isolate my issue down to a specific Blueprint. So I deleted all blueprints in my level and tried to package again. And this time it worked. So I was able to find out that it was a blueprint causing the packaging to fail.

So on a whim I tried one blueprint that I thought might be the cause, and sure enough I found it!

So I've recently in 4.13 made use of the new feature: "Blueprint functions can now be used to draw materials into render targets."

I've got an easel asset that makes use of this feature.

So I based my code on the examples, and I've managed to narrow it down to this.

If you create a Render Target 2D in the construction script it will cause the cooking to fail. I think this is most likely a bug.

I've tested it in the event graph and it works fine no problem on begin play.

So to recreate the bug.

Make a blueprint, in the construction script add "Create Render Target 2D" node and try to cook with that blueprint in the level.

Just need to confirm if this is a bug or an error on my part.

alt text

capture.png (30.6 kB)
avatar image r8ivy Nov 03 '16 at 04:23 PM

THANKS !!! did a bug ever get enterd for this? took my all day to find this page.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question