Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Failed to Launch Project


After finally reaching a state where I want to package my project and test it on other machines, i've come across an error while Launching my Project (Shipping, ByTheBook).

I have the log attached in here and hope it provides enough information for you to help me with my problem :)

mfg Heidi

Edit: File size exceeded, have a link: Click!

Product Version: UE 4.12
more ▼

asked Sep 10 '16 at 07:24 PM in Packaging & Deployment

avatar image

116 3 6 7

avatar image Heidi Sep 11 '16 at 08:12 AM

Anyone? ..

avatar image Steve Hardister ♦♦ STAFF Sep 13 '16 at 05:06 PM

Hi Heidi,

We do not accept files from the link you've provided. Please use a Google drive or Dropbox link if necessary, however a text file will generally not exceed file size.

To get a smaller output log file, open the Output Log, right-click and clear all data so that you are starting with a clean slate. Then try and package. When packaging fails, cut and paste contents of the Output Log into a text file and post. Again, this should not exceed the file size limit as we get many of these on a daily basis.


Steve H.

avatar image Steve Hardister ♦♦ STAFF Sep 16 '16 at 07:40 PM

Hi Heidi,

Since we have not heard back from you in a while, we are marking this post "resolved" for tracking purposes. However, if you are still unable to launch your project then respond with the requested information and we will continue to investigate.


Steve H.

avatar image Heidi Sep 19 '16 at 11:45 AM

Hi Steve, I didn't know about the upload causing problems, I've packed the txt into a rar to reduce its size and will reupload it here. This is still the old log, and I did not try repackaging with a clean slate yet as I am on a different pc.

I'm getting a lot of filename to long, but there are other errors in it aswell. I tried solving the filename to long issue a long time ago, but gave up after I noticed that the way I changed the names broke lots of references.

I still couldn't successfully package my Project with these settings. Packing in development/OnTheFly is working as intended.

Later today I might repackage the project to get a different error log, however this process took a lot of time, so might have to do it over night.

I hope you can help me out on this issue =) Thanks for the response!

projectlauncher.rar (211.9 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Heidi,

You have a struct error:

  1. UE4Editor-Cmd: [2016.09.10-17.40.14:204][ 0]LogProperty:Error: UStructProperty::Serialize Loading: Property 'StructProperty /Game/_Heidi/Widget/WLobbyClient.WLobbyClient_C:MapStruct'. Unknown structure.

And the rest of the errors are caused by file/directory names being too long for the Infinity Blade Assets.

The following AnswerHub post contains a couple of solutions to this: Can someone from unreal explain cook failures?

Steve H.

more ▼

answered Sep 19 '16 at 08:21 PM

avatar image Heidi Sep 21 '16 at 04:38 PM

After (hopefully) dealing with the longpaths, and the MapStruct I tried to compile my Project again, and got yet another error.

I've searched for it and found a similar thread here

I've commented on it with more information regarding that issue.

Thanks for helping me with the previous Log, I hopefully fixed the errors, but i cancled the Launching process after getting this error, so I am unsure. My WLobbyClient indeed had something missing regarding the MapStruct, which I could fix right away, just hadn't noticed it before.

If I'm having any problems regarding this thread i'll be back here =)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question