x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Always playing property of sound class not working in UE 4.13.

When i exit the falloff distance of an attenuated sound cue volume and come back, no sound plays.. I Even tried setting the sound class to always play but it still does not do what i need it to do. So is there any other way to make a sound continue playing within a specific radius so that when i come back into the radius, it plays from where i last left? Also the the setting of the sound class to always play use to work in previous versions of unreal. I've already tried this and it still does not work. https://answers.unrealengine.com/questions/123164/how-can-i-resume-an-out-of-range-sound-when-the-pl.html

Product Version: UE 4.13
Tags:
more ▼

asked Sep 10 '16 at 09:41 PM in Using UE4

avatar image

III47III
70 5 8 12

avatar image cj.allen321 Oct 13 '16 at 04:02 PM

Yes I'm experiencing this too. I tried making my own Master > Child sound classes and enabling always play on the Child in a newly created 1st Person Shooter template and when leaving the falloff zone, the sounds re-trigger from the beginning.

avatar image Megurine Nov 13 '16 at 12:29 AM

I have the same problem, and its really hard to make a musical FPS without this feature...

If someone have a solution or an engine fix pls !

avatar image sambrerio Mar 15 '17 at 04:31 PM

Do not work for me in 4.15.0

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

This functionality has been replaced with Virtualised Sounds, but always play options remain and don't function as far as I can see.

Enable master Virtualised Sounds check box in project settings > Audio, and tick the "allow sounds to be virtualised" check box on each SoundWave.

I will be profusely reading the changelogs from now on!

This doesn't seem to be documented anywhere though really.

Hope that helps, Chris.

more ▼

answered Nov 13 '16 at 08:58 AM

avatar image

cj.allen321
61 3 7 9

avatar image Megurine Nov 13 '16 at 02:58 PM

Oh ! Thank you very much !

It's perfect !

And effectively, the documentation should be updated ^^.

avatar image Megurine Nov 13 '16 at 05:12 PM

Ok, a little more information :

If you want to use the virtualised sound on a multiplayer project, the server heard all the sounds (after leave the falloff radius) but not the clients.

The client enter in the audio's radius, the music is hearded, he leave the radius , the music is not hearded and when he come back into the radius the music stay not hearded.

You need to use virtualised sound, annnnnd, i cant explain why, check the "Always play" checkbox in the class.

avatar image III47III Dec 10 '16 at 05:49 PM

Thank you very much, it works.

avatar image Galenan Feb 24 '17 at 02:05 PM

Thank you very much!!! It works perfectly.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Don't work for me, 4.19.1

more ▼

answered Apr 24 '18 at 04:15 PM

avatar image

PixelsDesign
11 1 3

avatar image Fredrum May 19 '18 at 05:40 AM

Or for me, 4.19.0

avatar image Sound Guy Roy Jun 30 '18 at 10:39 AM

For me as well in 4.19.2

avatar image MADHOUSE Jul 02 '18 at 06:10 AM

Yeah this doesn't work in 4.19 unfortunately..

avatar image Coverop Aug 19 '18 at 11:27 AM

This doesn't work in 4.20 :(

avatar image Coverop Aug 19 '18 at 02:14 PM

I'm bumping this because issue still exists in 4.20.. but It doesn't exists in 4.18??

I've attached link with a video below, explaining it a little bit. https://youtu.be/Mi9zCR2pa4g

avatar image cj.allen321 Aug 23 '18 at 05:31 AM

Ah, I was just making a test video to show it working and found the bug as far as I can tell. I did a video and absolutely showed it not working. I then went into Settings > Project Settings > Audio to check that "Allow Virtualized Sounds" was enabled, which it already was (and is by default) however the virtualisation then began working after I'd been into settings.

I wonder if opening the project settings is re-establishing the correct default states? It's definitely working in 4.19.2 for me, but only after opening settings.

I closed and opened the project too, and it stuck.

Hope that helps, Chris.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question