Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.13 degenerate tangent base error

Hello, I have been making modular components for robots for a while now, I make them up individually, unwrap and texture them, and then fit them together in different combinations and rig them up in 3ds for animation, using 3dsmax 2015 and 3dcoat as a means to both model and unwrap the models, I did this for two previous models, but for a recent one when I tried to import it, it gave me the "degenerate tangent base error".

This occurred after I have already exported the same model and uploaded it to sketchfab (https://skfb.ly/SMKY), all the smoothing and unwraps are correct, they had to be to upload to sketchfab, all the UVs are fine, and yet when I import into Unreal Engine it completely destroys those UVs (checked them tons of times), and completely gets rid of the smoothing and also gives me the degenerate tangent error, I really have no idea what's going on, especially considering I am doing the exact same thing that has worked in the past.

Anyone got any ideas?

Product Version: UE 4.13
more ▼

asked Sep 11 '16 at 08:54 AM in Bug Reports

avatar image

1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Moodydata,

The message warning about Degenerate Tangents isn't a bug, but is just indicating that the UV is not unwrapped properly so you'll get this warning because the tangents are not calculated correctly because of it.

By Default the importer uses MikkTSpace tangent space which is more accurate, but you can switch to the old built-in method that won't report any tangent issues since it uses a different method of calculation. You can do this by switching it in the import options or going to the Build Settings in the Static Mesh Editor and unchecking MikkTSpace and then hitting apply.

This has been pretty well covered in other questions on the AnswerHub and Forums.

I hope this helps.


more ▼

answered Sep 12 '16 at 02:30 PM

avatar image

Tim Hobson ♦♦ STAFF
48.7k 888 103 880

avatar image xdeviloper Nov 08 '17 at 01:00 AM

In my case I just export mesh from UE and open in 3d Max, and i have got this problem after import fbx in UE after Max.

This is example:

Before Max: alt text

After Max: alt text

If i tried follow your suggestion, i did't get error message, but have got same result with degenerate tangents.

And the solution:

Just uncheck "Smoothing Group" while importing mesh in 3d Max. alt text

Maybe it may help someone :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question