x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

ios deploy error

I have the provision / certificates as verified with the bundle identifier entered (after generating in xcode).

I keep getting an error at the end of the process while it tries to transfer over to the iphone (Launch on my connected device - iphone 6). Also fails if I try to package to IOS and not through the launch menu.

Program.Main: AutomationTool exiting with ExitCode=32 (Error_FailedToCodeSign) RunUAT ERROR: AutomationTool was unable to run successfully.

simple test scene just to resolve this export (a few cubes basically)

can't get past this - any advice??

Product Version: Not Selected
Tags:
more ▼

asked Sep 11 '16 at 09:08 PM in Packaging & Deployment

avatar image

blivny
21 1 2 2

avatar image FacePalm.exe Sep 11 '16 at 11:25 PM

Couple of questions I guess:

What version of the engine are you on?

Are you running the full code version of the engine or the pre-built version?

Are you trying to deploy on PC or Mac?

Can you post a copy of the full build log? (snip any personal ID's) That's not enough info to go off currently.

avatar image blivny Sep 12 '16 at 11:53 AM

Thanks for your response, here is more info-

  1. Version: 4.13.0-3106830+++UE4+Release-4.13

  2. Believe it's the pre-built version. simply installed from within the epic launcher the most recent version.

  3. running on a mac osx El Capitan 10.11.5

  4. under project settings - ios I see the Provision and Certificate as both valid

I tested a similar workflow with unity and it worked - similar process for getting the provision / certificate. I don't have a developers account with apple yet (it's set as a temp for testing on my device only). I created a blank x-code project with the same bundle identifier and received certificates through that ( built it and placed it on the phone through x-code to make sure it works). I then used it in unreal - and the certificates loads ok (valid).

I see the problem has to do with these lines in the log -

UATHelper: Packaging (iOS): env: Check dependencies UATHelper: Packaging (iOS): env: Provisioning profile "iOS Team Provisioning Profile: tv.IOS-Livny.livny.IOS-TEST2" is Xcode managed, but signing settings require a manually managed profile. UATHelper: Packaging (iOS): env: Code signing is required for product type 'Application' in SDK 'iOS 10.0'

full log included in the attachment.

is there a way to use my certificates as a "manually managed profile"? I can download the provision but not the certificate - they do link with my user / bundle identifier in unreal.

Thanks again!

link text

log.txt (192.6 kB)
avatar image blivny Sep 12 '16 at 01:24 PM

update

created a development profile and followed the steps in the help file. downloaded the certificate and provisioning profile and applied successfully in unreal. still getting this error-

LogPlayLevel: env: Provisioning profile "iphone_profile" doesn't include signing certificate "iPhone Distribution: my name (omitted)". LogPlayLevel: env: Code signing is required for product type 'Application' in SDK 'iOS 10.0'

avatar image FacePalm.exe Sep 12 '16 at 02:50 PM

That last bit sounds like you created the profile without adding the user certificate to it. (Or more likely the wrong type)

Are you trying to apply a distribution provisioning profile instead of a development one?

avatar image blivny Sep 12 '16 at 11:11 PM

first, thanks for getting back.

it is development. basically under the apple development certificates. identifiers, and profiles section I have one provisioning profile under development (IOS Development as type) and is active. when i press it I can see 1 noted for certificate and 1 for device, and the app ID matches what I'm using in Unreal (with a wildcard). I apply it in unreal and change the wildcard section to a unique name for the test and everything appears to register ok.

if I press edit under my provisioning profile, I can see my IOS Development certificate present and selected under the certificates section.

for the certificate, under the top Certificates section of the page, I have one IOS development certificate that appears active and is the same mentioned earlier noted under the provisioning profile.

I did this on the Mac and did not need to do the key-pair as noted in the instructions for a PC. meaning I never generated such a file to send to apple, but all the contents here appear correct and under the development scope.

As a side note I am also trying to do it on a PC but there it asks for the key-pair i generated, and of course that doesn’t work for me. Especially since I can only have one certificate under apple - I see IOS App Development as grayed out so I can’t create another one with the key pair.

do you have some experience with managing these things? do i need to create a new one with a key pair - if so how does that enable me to develop on a mac, suppose the main issue is to get the process to work so I can do R&D with unreal..

Thanks again.

avatar image FacePalm.exe Sep 14 '16 at 12:36 AM

It looks like you're signing with the Distribution certificate specifically because the log you pasted states iPhone Distribution instead of iPhone Developer

If it's trying to use the distribution certificate which you don't have a provisioning profile for, then it will obviously fail.

Check in the Editor settings that you're not trying to build 'For Distribution' (Project > Packaging > Packaging > For Distribution)

Generally you want to be creating your certificates via XCode. (Rather than the convoluted certificate request method) These will show up in your mac keychain.

The only time you should need to create Provisioning profiles is for a new Bundle ID. It needs to not be a wild card profile (so not com.companyname.*) and you should create a development one and a distro one (for uploading to testflight/app store) And you should only ever need two keypairs (one distro, one development).

As for the launching from PC: you can export your certificate by going to Xcode > Preferences > Accounts > View Details (with your team selected) > Signing Identities > Right click on iOS Development and hit "Export" Then Input a password and export the .p12 file to a folder on your PC (or USB stick)

NOTE: It NEEDS to be a .p12 NOT .cer so it has the private key in it.

The editor generally has trouble importing certificates, so go to: UE4Directory\Engine\Binaries\DotNET\IOS\IPhonePackager.exe, Find the uproject file for your project, then click the Already Registered tab, and import your certificate through there. You can manage it using certmgr.msc. It should import to your personal certificates.

avatar image Steve Hardister ♦♦ STAFF Sep 13 '16 at 08:55 PM

Are you using XCode 6 or XCode 7? Googling the term "Xcode managed, but signing settings require a manually managed profile..." there are different solutions for refreshing the provisioning files for each version, which I suggest you try.

Searching our database, I found a user that was experiencing the same error in the following forum thread. While nothing jumped out at me as a clear solution, there's posted a couple of things you can try that may resolve the issue:

Can't package or launch to iPhone5c from Macbook Pro - code sign error

avatar image Steve Hardister ♦♦ STAFF Sep 19 '16 at 05:13 PM

Hi blivny,

Since we have not heard back from you in a while, we are marking this post "resolved" for tracking purposes. However, if you are still having a problem launching on or packaging for an iOS device, please respond with the requested information and we will continue to investigate.

Thanks,

Steve H.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Thanks,

I got it working. a few points (not sure what fixed it) - I opened up a dummy project in x-code and compiled with the certificateI have from the dev site (not sure if it helped). I then exported it out of keychain as a cer format and also personal information exchange format (one of them worked).

the distribution name you saw was just my renaming it on export troubleshooting (they had always been dev certificates)

thanks again for the support.

more ▼

answered Sep 19 '16 at 05:25 PM

avatar image

blivny
21 1 2 2

avatar image Steve Hardister ♦♦ STAFF Sep 19 '16 at 07:57 PM

Thanks for posting your resolution -This may help someone in a similar situation.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question