x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Ue4 laggy when 2 screens open

Whenever I have 2 windows open ue4 runs fine, but if I have two windows open (such as blueprint open on another monitor) the engine seems to simulate the physics wrong and drops it's framerate heavily.

Specs: i7 6700k GTX 1080 16 GB DDR 3000

Product Version: UE 4.12
Tags:
more ▼

asked Sep 14 '16 at 02:15 AM in Installation & Setup

avatar image

reporttheloss
11 1 2 3

avatar image Matthew J ♦♦ STAFF Sep 14 '16 at 12:40 PM

Hello reporttheloss,

What kind of display setup are you using? What are the resolutions of these two monitors? How are they connected? Is it through Display Port, HDMI, DVI etc.? Are both of the monitors connected to your GTX 1080 or is one on an integrated graphics card?

Have you used a previous version of the engine where this doesn't happen or was 4.12 your first one? I would be interested to know if this is version-specific or not.

avatar image reporttheloss Sep 14 '16 at 05:36 PM

Right now I have 2 monitors; both 1920x1080 with 1 using dual-link DVI and 1 using HDMI both plugged directly into the GPU. This is a new PC, but on a previous pc with lesser specs (gtx 970) I had the exact same setup with no issues. I'm currently using 4.12.5, which is the same as on the other system.

avatar image Matthew J ♦♦ STAFF Sep 15 '16 at 05:55 PM

Thank you for that information, to get some more information about what might be causing this, what current graphics driver are you on? When you're experiencing the laggy behavior, can you run some sort of monitoring software to look at your GPU usage and temperature? Monitoring the CPU usage would be useful as well. I wouldn't imagine that it would be taxing your setup that much, especially if the project isn't large, but it would be good to test.

Also, since I didn't ask this before, is this behavior something that you're only seeing in one particular project or even in a new blank project?

I'm sure it seems like I'm asking a lot of questions but it's due to not seeing an issue such as this before, as it usually is caused by some weird display setup but yours seems normal.

avatar image reporttheloss Sep 19 '16 at 06:15 PM

I am currently on v372.70. I looked at the GPU usage and temperature, it peaked at 11% usage and 36 C. My cpu peaked at 37 C with a 26% usage. The behavior is on every project so far in 4.13 and 4.12.5 on previous project I have been working on as well as new projects started from scratch.

avatar image reporttheloss Sep 19 '16 at 06:18 PM

if it is any more help, it seems as if the physics are being simulated improperly when I drag a window off such that it behaves completely different and much slower than when I just have one screen in use. I also noticed some lag when in the menus themselves.

avatar image Matthew J ♦♦ STAFF Sep 22 '16 at 09:30 PM

Hello reporttheloss,

From testing this and speaking with others, this seems to be expected behavior. The reason the framedrops happen is due to literally double the rendering when you have it on both screens as opposed to one, since overlapping means less rendering. As far as the physics simulation difference is concerned, this is due to Phys X being related to the framerate and the calculations being different at different amounts.

Hope this helps, Have a nice day.

avatar image reporttheloss Sep 23 '16 at 12:06 AM

This makes literally no sense. I ran the exact same project in the same version of the engine on a computer with lower specs (gtx 970) and was able to run 3 monitors just fine. Now I have a faster machine and this is to be expected?? You didn't help me at all..The program becomes essentially un-usable, not just frame drops.

avatar image Matthew J ♦♦ STAFF Sep 23 '16 at 12:27 PM

I apologize, that's my fault. I had this mixed up with another post and forgot that you had seen better results on a computer with a lesser graphics card. Would it be possible for you to provide the full specs of both of these computers, such as their dxdiag information? Please be aware that the graphics card isn't all that affects the framerate. This could also be affected by the version of windows on both of the computers among other things. Also, have you tried using any older graphics drivers for the 1080? The newest ones, especially if they're "Game Ready" drivers, may not be the most optimal for the editor.

avatar image reporttheloss Sep 29 '16 at 06:18 PM

Here is the dxdiag info in text format of the computer in question. I do not have access to the other computer as I am living in a different part of the country for now. I have not tried using older graphics drivers at this time.

[1]: /storage/temp/108988-dxdiag.txt

dxdiag.txt (83.0 kB)
avatar image Matthew J ♦♦ STAFF Sep 30 '16 at 09:16 PM

Hello reporttheloss,

It just became known to me from someone in our QA department that there are currently some known compatibility issues with the graphics driver you're using, 372.70. I would suggest using either a newer driver (if available) or rolling back to the previous driver. Please let me know if this driver changes helps with your performance issues.

avatar image LoN Oct 06 '16 at 08:32 PM

Hello guys, i have exactly the same setup but with 32 gb ram and GTX 1070 and the same driver, The framerate drops really low if i have at least one bp window open and it shows the nodes with the simulation. if the bp window does not show the nodes, the editor is ok.

Take a lok at what i mean:alt text

In the 2nd picture i have dragged the nodes so they are not showing and the framerate is better.

alt text

-------EDIT------

I updated the nvidia driver to 373.06 but nothing changed.

ue4bad.jpg (574.7 kB)
ue4ok.jpg (515.3 kB)
avatar image Matthew J ♦♦ STAFF Oct 12 '16 at 01:50 PM

Hello LoN,

If you're experiencing lower framerate when the nodes are visible, that would be expected because with those nodes visible, your computer is having to render additional things which would cause lower framerate but only to an extent. How much of a difference is it making? Try entering "stat fps" into the console to get an exact value.

@reporttheloss Have you had a chance to try a different driver? If so, what were the results?

avatar image LoN Oct 21 '16 at 07:23 AM

As you can see the difference is really big.

With the nodes open i have about 30 FPS and without them open i've got 120 FPS. I've also updated the nvidia driver to 373.06.

alt text

alt text

pic_01.jpg (613.2 kB)
pic_02.jpg (589.7 kB)
avatar image reporttheloss Sep 23 '16 at 12:46 AM

It even lags when the "restore old windows" popup comes up when opening up a previously open project. I really do not think this is to be expected

avatar image apq Dec 01 '17 at 04:30 PM

I have the same issue with a GTX1080 card on 388.31 drivers. I get heavy lag in the editor, with framerate dropping from around 100 to about 5 FPS. It works occasionally but then starts lagging again after a while. It mostly happens when I have one or more windows on my second monitor, for example the Content Browser. If I minimize the Content Browser, or dock in in my main window it stops lagging.

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

We haven't heard from you in a while, reporttheloss & LoN. Are either of you still experiencing this issue? @reporttheloss, was the graphics driver change able to help you with this issue? @LoN could you provide the information I requested in my previous comment? In the meantime, I'll be marking this issue as resolved for tracking purposes.

more ▼

answered Oct 20 '16 at 05:22 PM

avatar image

Matthew J ♦♦ STAFF
31.8k 526 91 417

avatar image Shadur Mar 10 '18 at 03:55 PM

Hello! I have the same issue on my setup. I have setup my screen layout to have the World Settings and the Details on the other monitor, just a tiny little window, but as soon as I have it up, sometimes it drops my FPS around 40 frames and sometimes it completely goes down to ~20 fps. As soon as I minimize the window on the other screen the fps goes back up again.

Comp specs: GTX 980Ti, Intel i7-4790, 16 gb's of ram, running off of an SSD.

Both monitors are hooked up the same graphics card and through DisplayPort.

Cheers,

Shad

// EDIT: Seems to be an issue with Nvidia GeforceExperience, I went to the Settings tab, under General and disabled NGE In-Game Overlay and the issue seemed to go away.

(comments are locked)
10|2000 characters needed characters left

Thank you for that clarification, LoN. I've reproduced this locally, on a smaller scale, and entered a bug report for the issue under the following number: UE-37659. It's possible that this may come back as intended functionality but we'll see what the developers in charge of this think about this.

more ▼

answered Oct 21 '16 at 05:15 PM

avatar image

Matthew J ♦♦ STAFF
31.8k 526 91 417

avatar image Vaei Jan 03 '18 at 10:42 PM

I'm experiencing this to a severe degree. 980ti gpu, 16gb corsair vengeance ram @2666mhz, i7 6-core/12thread @ 4.5ghz. GPU and CPU run stable.

avatar image Kriptanik Jan 12 '19 at 08:16 AM

Hey guys, does anyone have a solution to this issue yet?

Right now I'm going from 70FPS with the main editor window and blueprint window open to 120FPS with just the editor open (and blueprints minimized).

Having to minimize and maximize my blueprint windows 100s of times a day every time I preview a scene is driving me crazy. We just need a tickbox to disable realtime rendering of the blueprint window when it's not in focus/when previewing a scene.

This has been happening for years my old PC has the same issue, surely we can do something about this?

Thanks.

(comments are locked)
10|2000 characters needed characters left

You may be limiting your fps, normally when using NVIDIA Experience or Rivatuner

more ▼

answered Jan 23 '19 at 01:39 PM

avatar image

GTNardy
1 1 2

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question