x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.13 Audio Spatialization problem

I have just converted my project from 4.12 to 4.13 and have a weird audio spatialization problem.

I have 5 audio components around the room which play my audio track. in 4.12 they played continually even if I was not in range to hear the audio component. this was what I wanted so that they all played the song in unison.

When I converted to 4.13 each component seems to stop playing its audio cue when I'm not in range to hear it and then starts from the start of the sound cue when I come back into range. there for when I'm in range of multiple audio components within the blueprint they are all playing the music from different points along the track. it sounds terrible.

I've probably just missed a check box somewhere. here is a screen shot of my blueprint: alt text

any help apriciated tnx

Product Version: UE 4.13
Tags:
more ▼

asked Sep 14 '16 at 01:34 PM in Blueprint Scripting

avatar image

LiquidJoy
23 10 16 19

avatar image Zilphy Sep 14 '16 at 01:54 PM

I have the same issue, I'd like to see what the solution is! I was able to workaround by setting up my blueprints to set the volume to just very low and not 0, like 0.01 or something when out of range.

avatar image Minus_Kelvin STAFF Sep 14 '16 at 05:24 PM

We made playing at 0-volume opt-in for 4.13. I'll see if I can add this to release notes post-release. It was a decision made last minute due to performance issues we noticed due to decoding many silent sounds. To recover the old behavior, just make sure your sound waves that you want to continue playing even at 0-volume have the bVirtualizeWhenSilent check. Eventually (hopefully soon) this will enable real virtual voices. Right now, it just doesn't stop the sound when it gets to 0-volume.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question