x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android packaging unknown error

Every time i try packaging my game for android I get a unknown error at the end and the folder in which I try to create the game is empty. When i make it for Windows it works fine. I also get the same unknown error when i try to package project Tappy Chicken game.
I have tried several times to reinstall CodeWorksforAndroid, but still i get the same problem.link text

I am new to Unreal Engine and i could use some help at this matter.

Product Version: UE 4.13
Tags:
spēlerun.log (254.9 kB)
more ▼

asked Sep 17 '16 at 10:52 AM in Packaging & Deployment

avatar image

Cashmere Cloud
1 1 3 5

avatar image Cashmere Cloud Sep 17 '16 at 03:23 PM

I tried migratig files to new project but it also did not work. [link text][1] This is where the errors start to show up. [1]: /storage/temp/107444-thingsgetmessy.txt

thingsgetmessy.txt (10.3 kB)
avatar image Cashmere Cloud Sep 19 '16 at 01:02 PM

alt text How it looks!

untitled.png (250.0 kB)
avatar image Samantha Sutton ♦♦ STAFF Sep 22 '16 at 03:46 PM

Cashmere Cloud,

  • Delete your Intermediate and Saved folders from your project.

  • Please make sure you've added your Android SDK information to the Project Settings > Android SDK section in the editor. Example:

Android SDK

  • Please make sure you've followed the Android Documentation for setting up Android Development.

  • Make sure your CodeWorks is using 1R4u2 example:

CodeWorks Example

If you are unsure, please upload screenshots of your own, thanks!

avatar image Cashmere Cloud Sep 23 '16 at 03:47 PM

Thanks for the replay! I tried what you said. Installed CodeWorks 1R4u2. Set up Platforms Android-SDK and deleted Intermediate and Saved folders. But i still cant package my project. I get an error that it cant find Intermediate/Android/APK/bin/[NAME]-debug.apk. alt text

link text

alt text

newlog.log (272.0 kB)
untitled1.png (38.7 kB)
untitled2.png (251.8 kB)
avatar image Samantha Sutton ♦♦ STAFF Sep 23 '16 at 08:29 PM
 This is the error I see: Error reading project file E:\Sp?leRun 4.13\Sp?leRun 4.13\Intermediate\Android\APK\build.xml: Invalid byte 2 of 3-byte UTF-8 sequence.

If you delete this folder: E:\Sp?leRun 4.13\Sp?leRun 4.13\Intermediate\Android while the editor is closed and see if that resolves the issue. It should recreate that file that is stating it's invalid.

avatar image Cashmere Cloud Sep 24 '16 at 10:51 AM

Thank you for the response! I tried to delete the Android folder when the engine was closed. But when I tried to package I got the same error. Could not find a part of the path 'E:\SpēleRun 4.13\SpēleRun 4.13\Intermediate/Android/APK/bin/SpēleRun-debug.apk

alt text link text

spēlerun.log (293.9 kB)
sameerror.png (247.1 kB)
avatar image Samantha Sutton ♦♦ STAFF Sep 26 '16 at 09:30 PM

Can you create a blank project and see if it'll package for you? Basically, if your project is only blueprint, create a blueprint project, if it's both, then set it up that way, etc.

I'm looking into the character encoding error I see and will get back to you as soon as I can. In the meantime, please check the packaging in Android of a blank project for me.

Thanks!

avatar image Cashmere Cloud Sep 26 '16 at 10:01 PM

I made a blank blueprint project (Mobile/Tablet; Scalable 3D or 2D; No starter content). And I still got the same error I got in the beginning, even when I deleted the Intermediate and Saved folders. It seems it might not be link textthe project fault.

myproject.log (245.5 kB)
avatar image Samantha Sutton ♦♦ STAFF Sep 27 '16 at 02:48 PM
avatar image Cashmere Cloud Sep 28 '16 at 11:06 AM

I tried running as Administrator, but it did not work. I dont think that the issue is the same as in that post. And I am not sure if I could implement the solution that was used there since my project is all blueprints. I also did go through the Android SDK set up. I have tried going through it several times. The only difference I see is that I use VS 2015 not 2013, but it would matter if my project had C++ code.

avatar image Samantha Sutton ♦♦ STAFF Sep 28 '16 at 02:56 PM

4.13 requires VS2015 - so you should be fine there. Other helpful tips I have been able to locate regarding this error is that moving the NDK may help. Just make sure that where you move it doesn't have any spaces in the file path. Another suggestion is to change the API level to 'latest'.

avatar image Cashmere Cloud Sep 28 '16 at 09:47 PM

So i need to move the android-ndk-r11c folder someplace else?

I tried changing NDK and SDK API level (both, only SDK and only NDK), but no luck. Moving the NDK if I did how I think I had to do it had no result.

avatar image Samantha Sutton ♦♦ STAFF Oct 04 '16 at 03:01 PM

Have you tried renaming your project entirely from "SpēleRun" to "SpeleRun"? It might just be the ē causing the whole issue.

avatar image Cashmere Cloud Oct 05 '16 at 03:35 PM

I did try it with this tutorial, but still got the error. http://www.worldofleveldesign.com/categories/ue4/ue4-renaming-your-project.php

avatar image Samantha Sutton ♦♦ STAFF Oct 05 '16 at 05:55 PM

Did you verify that it changed it within all of the project settings? If not, double check that Project Settings > Project - Description has been updated as well as Project Settings > Platforms - Android > APKPackaging

Make sure that once you modify the settings, you delete your Saved and Intermediate folders.

Provide updated logs as needed, thanks!

avatar image Cashmere Cloud Oct 06 '16 at 06:46 PM

Will All the name changing my project packaged further then before, but I got another Error at the end. This is how it looks. Is the APKPackaging and Project Description is correct? I very appreciate all the help you have given me. alt textalt text

alt text

link text

spelerun.log (381.1 kB)
new-error.png (200.6 kB)
description.png (92.3 kB)
avatar image Samantha Sutton ♦♦ STAFF Oct 06 '16 at 09:55 PM

Based on the error that I see:

 [2016.10.06-18.30.04:702][506]UATHelper: Packaging (Android (ETC1)): Program.Main: ERROR: AutomationTool terminated with exception: System.IO.FileNotFoundException: Could not find file 'E:\SpeleRun 4.13\SpeleRun 4.13\Intermediate/Android/APK/bin/SpeleRun-debug.apk'.
 
 [2016.10.06-18.30.04:703][506]UATHelper: Packaging (Android (ETC1)): File name: 'E:\SpeleRun 4.13\SpeleRun 4.13\Intermediate/Android/APK/bin/SpeleRun-debug.apk'

You should be able to delete the Intermediate and Saved folder from your project and it should get over this point.

I am concerned about: E:\SpeleRun 4.13\SpeleRun 4.13\Intermediate\Android\APK\bin\AndroidManifest.xml:1: Tag attribute package has invalid character '['.

But that should be resolved too, once the Intermediate folder is deleted.

You're welcome for all of the support, sometimes these issues are tricky and other times they're a breeze. :)

avatar image Cashmere Cloud Oct 07 '16 at 05:38 PM

I deleted the folders, but still get (Tag attribute package has invalid character ''.) and ('E:\SpeleRun 4.13\SpeleRun 4.13\Intermediate/Android/APK/bin/SpeleRun-debug.apk'.)[link text

avatar image Samantha Sutton ♦♦ STAFF Oct 10 '16 at 03:21 PM

Can you send me that file?

E:\SpeleRun 4.13\SpeleRun 4.13\Intermediate\Android\APK\bin\AndroidManifest.xml

Thanks!

avatar image Cashmere Cloud Oct 10 '16 at 05:19 PM

When I tried to send file it said: This attachment is not permitted because the file type is invalid. So i made a rar file (No viruses. I promise).link text

avatar image Samantha Sutton ♦♦ STAFF Oct 11 '16 at 02:08 PM

Replace your old .xml file with this one, let me see the logs if there is a failure. Upload screenshots of your Project Settings > Packaging and your Project Settings > Platforms - Android

Thanks!

AndroidManifest.rar

avatar image Cashmere Cloud Oct 11 '16 at 09:18 PM

The error still occurred when I changed the AndroidMainfest.xml. Here are the screenshots and the log. alt text link text alt text alt text

spelerun.log (385.6 kB)
error.png (155.7 kB)
packaging1.png (75.0 kB)
packaging2.png (77.2 kB)
avatar image Cashmere Cloud Oct 11 '16 at 09:20 PM

alt text alt text alt text alt text

avatar image Samantha Sutton ♦♦ STAFF Oct 12 '16 at 05:15 PM

Please remove the [] from your APKPackaging Android Package name section. Here's your screenshot.

That's what I removed in the XML file that should resolve the []. Sadly some special characters cause trouble when packaging, which can be frustrating.

Let me know!

avatar image Cashmere Cloud Oct 13 '16 at 09:59 PM

I removed [] and the packaging went further, but still hit an error. It seams like this one might be related to the fact that I have a weird windows account logo in the user name. I did rename the user, but when I packaged the game unreal engine created a user folder with that weird logo. And went for a android\debug.keystore from it not from the user with the changed normal name. Is there a way to make it go for the android\debug.keystore from a different user account? (I might also be wrong with my theory) link text

alt text

spelerun.log (424.9 kB)
untitled.png (10.7 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first
 [2016.10.13-21.46.53:755][432]UATHelper: Packaging (Android (ETC1)): [apkbuilder] Creating SpeleRun-debug-unaligned.apk and signing it with a debug key...
 [2016.10.13-21.46.54:751][435]UATHelper: Packaging (Android (ETC1)): [apkbuilder] keytool error: java.io.FileNotFoundException: C:\Users\?Admin\.android\debug.keystore (The filename, directory name, or volume label syntax is incorrect)
 

Are you using the correct keystore?

more ▼

answered Oct 14 '16 at 05:36 PM

avatar image Cashmere Cloud Oct 14 '16 at 10:12 PM

It worked! Thank you so much! All this nightmare which I brought upon us resulted in success.

avatar image Samantha Sutton ♦♦ STAFF Oct 17 '16 at 05:04 PM

You're welcome! :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question