x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot set an animation sequence as idle pose even it has the same skeleton as the Animation Blueprint

Hi, Unreal Pros,

I hope it's not due to my a bit outdated version of Unreal Engine, but I encountered a weird problem in Animation Blueprint.

I just bought a animation set from Unreal marketplace. I import it faithfully into my existing project because it has retargeted to UE4_Mannequin(from animation starter pack.) And also all of my animation blueprints and animation montages before are using the very same UE4_Mannequin.

As expected, I can drag & apply the sequence into the animation montage using the UE4_Mannequin without any problem.

But when I try to drag the idle pose of the bought material into the AnimGraph area of an animation blueprint window. It says "Skeletons are NOT compatible." How could that be possible? This animation blueprint use the very same skeleton as the AnimMontage I just mentioned, and the idle pose I added is targeted to UE4_Mannequin as well !!

Can somebody give me suggestions about what could be the problems?

Product Version: UE 4.11
Tags:
more ▼

asked Sep 17 '16 at 01:35 PM in Using UE4

avatar image

sbbg
6 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Okay, I did find out why does this happen.

I'm answering if someone does visit this thread.

The problem I met that the animation sequence is not shown or listed for a skeleton is actually due to the duplicate of the skeleton. Although the new skeleton DOES has very same structure as the original, but UE4Editor still treat them as TWO skeletons because they're 2 different files.

So the conclusion is: Your have to (1)retarget it or (2)replace the reference for the animation sequence to make it compatible with the skeleton you want. And (2) is only available if the structure of new and old skeletons have very same structure. (Bone name and hierarchy)

more ▼

answered Nov 15 '17 at 08:43 AM

avatar image

sbbg
6 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question