x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Installed app on android can't be launched

I seem two have either of two probles:

  • I succesfully install the unreal app via the .bat file on my Samsung S7 with Android 6, but then it shows the warning that the apk is not signed. I've had problems finding the right folder for the .keystore file, I guess that's sorted now but then the second problem arrives:

  • After installing the app via the .bat file, no shortcut is created on my Android device, so I can't open the app. When checking the app list in Android settings, it says it is installed.

Does someone know how it can be that no shortcut is created on the Samsung S7? Where do I go wrong/where should I look to fix this?

Product Version: UE 4.13
Tags:
more ▼

asked Sep 17 '16 at 02:43 PM in Packaging & Deployment

avatar image

Rchv
26 3 5 6

avatar image Samantha Sutton ♦♦ STAFF Sep 21 '16 at 05:30 PM

Rchv,

  • Are there any logs that you can provide, or any errors that are showing up in the command prompt, or even from the editor?

  • Did you make sure that you accepted your computer fingerprint on your device?

  • Did you set up the developer settings?

Please follow the steps from the Android Quick Start to ensure you've set up your computer and device correctly for game development and testing.

Thanks!

avatar image Rchv Sep 22 '16 at 02:17 PM

Thanks for your reply Samantha,

There's no error in the log, it says build succesful, and succesfully creates the .bat file to install the app on my phone. That .bat file runs as well. Also the phone is set up with the developer settings enabled and gets the app installed (it shows up in the installed apps list). However there's no shortcut to pen the app.

Some thoughts: in the quick start api level 19 is advised (APK packaging and SDK settings) but the Samsung S7 uses 23, could that create problems? what should be installed/not be installed in the Android SDK manager, I couldn't find anything on this topic.

avatar image Samantha Sutton ♦♦ STAFF Sep 22 '16 at 04:16 PM

If you're packaging for ARM64 using Android-19 it would cause problems because the headers aren't supported for ARM64 with Android-19.

Can you provide me step by step instructions on how you're packaging your project, what packaging settings you're using in the project, etc?

Thank you!

avatar image Rchv Sep 25 '16 at 07:20 PM

Where do I checked wether it is packaged for ARM64?

avatar image Rchv Sep 25 '16 at 07:20 PM

The steps I follow: (taken from the quick start manual https://docs.unrealengine.com/latest/INT/Platforms/GearVR/QuickStart/index.html)

  • I create a default first person blueprint project, setting set to Mobile/tablet, Scalable 3d/2d, No starter content

  • In plugins, at Virtual Reality I set Gear VR and Oculus Library enabled, disable others

  • In project settings, at Android, I click configure now for APK packaging, set minimum target SDK to 19, enable Configure the AndroidManifest for VR

  • Also in project settings, Packaging I have full rebuild en for Distribution enabled.

  • previously I have CodeWorks for Android installed, the one I can select to install is 1R5, altough 1R4 is available by a pull down menu. I there install the ANdroid SDK, Android 6.0 options, all of Android Toolchain, Developer Tools, USB Driver, Middleware. In project settings, Android SDK the pathes etc have been set up. I set the NDK api level to 19 a described in the quick start(have tried 23 but it results in error)

  • I create the keystore file as described here In Build/Android folder: https://wiki.unrealengine.com/How_To_Sign_UE4_Android_Package

  • connect my Samsung S7 with Android 6.0.1, Samsung usb drivers installed

  • I package ETC2, the install files are created and I run the .bat file

  • No shortcut is created on my phone, however it is listed in the apps list on my phone with 106 mb installed.

  • Developer options are enabled on the phone

I Use Windows 10, Unreal 4.13

I sincerely hope you can help me to solve this, I am totally stuck at this point. I wonder if the settings are correct for the Samsung S7 since it has Android 6. Also I have no experience with CodeWorks..

avatar image Samantha Sutton ♦♦ STAFF Sep 27 '16 at 03:03 PM

Check under Project Settings > Android > Build: then make sure that Support ARM64 isn't selected.

Also, we do not push the application shortcuts to the "desktop" of the device. Some phones do it while others do not, they always install to the apps folder.

Thanks!

avatar image Rchv Sep 29 '16 at 03:38 PM

The ARM64 wasn't selected in project settings. However, my Samsung S7 has an ARM64-v8a processor. How to handle this?

avatar image Samantha Sutton ♦♦ STAFF Sep 29 '16 at 08:20 PM

Have you tried turning 'Online Subsystem GooglePlay' off? I'm not having any trouble deploying Android-19 to S7. So that shouldn't be a problem but I do know we're having trouble with the Online Subsystem GooglePlay especially when ARM64 is enabled.

Have you tested with 4.13.1 yet?

avatar image Rchv Oct 03 '16 at 02:05 PM

I switched 'Online Subsystem GooglePlay' off in Plugins and disabled ARM64. It builds successfully (now with 4.13.1), I then run the .bat file. On my phone I create a shortcut to my app and launch it. It then asks to be placed in the Gear VR, then the app immediately stops unexpectedly and the message appears "Thread priority security exception, make sure the apk is signed"

I successfully created the .keystore file as described in the tutorial: https://wiki.unrealengine.com/How_To_Sign_UE4_Android_Package

Am I still mistaken somewhere in the Packaging steps?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I was so focused on the package settings, I lost the osig file out of sight. So I followed the steps here: https://dashboard.oculus.com/tools/osig-generator/ And now it works!

more ▼

answered Oct 05 '16 at 12:17 PM

avatar image

Rchv
26 3 5 6

avatar image Samantha Sutton ♦♦ STAFF Oct 07 '16 at 08:43 PM

So glad to hear that the issue has been resolved. Please let us know if you have any further questions. :)

  • Samantha

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question