x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Media Sound Wave not playing while player re-enter the sound area

I'm using the Media Framework 2.0 to play some sound of video.

It works fine when Media Player start. (Playing sound at some location with attenuation). Then I leaves the fallout area, the sound stops correctly.

But when I re-enter the sound area, the sound never come back. Am I doing something wrong?

Any ideas would be appreciated!

Product Version: UE 4.13
Tags:
more ▼

asked Sep 19 '16 at 10:08 AM in Using UE4

avatar image

Adcentury
37 4 9 14

avatar image lordbunson May 30 '17 at 09:33 PM

This still seems to be occurring. Has anyone opened up an issue for this yet? I'd like to upvote it.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Starting with 4.13, we're stopping sounds when they reach zero volume. It was too expensive to have them all running. Zero volume sounds are now opt-in. You can enable it with an option on the (Media-)SoundWave assets... it's called bVirtualizeWhenSilent or something like that.

more ▼

answered Sep 19 '16 at 06:17 PM

avatar image Adcentury Sep 20 '16 at 05:06 AM

Thanks for replying.

I'm using C++ and I find code in class SoundWave:

 /** Allows sound to play at 0 volume, otherwise will stop the sound when the sound is silent. */
 UPROPERTY(EditAnywhere, Category=Sound)
 uint32 bVirtualizeWhenSilent:1;

However, this variable is private so it seems I have no chance to modify it. Could you tell me how to set this variable to true?.

avatar image Adcentury Sep 20 '16 at 05:57 AM

I found that I can set bVirtualizeWhenSilent directly in the code. But even when I set bVirtualizeWhenSilent to true, sounds not come back when I re-enter the sound area.

I debug the code and find the only place using bVirtualizeWhenSilent is

 if (WaveInstance->GetVolume() > KINDA_SMALL_NUMBER || (bVirtualizeWhenSilent && AudioDevice->VirtualSoundsEnabled()))
 {
     WaveInstances.Add(WaveInstance);
 }

And it seems AudioDevice->VirtualSoundsEnabled() always return false. Is there any way to make it true?

Btw, I'm using SpawnSoundAttached to play the media sound wave.

Thanks a lot.

avatar image Adcentury Sep 20 '16 at 06:06 AM

I got the way to modify Default Audio Settings.

For someone who may meet the same situation, here is the way to make (Media-)SoundWave "virtual" play when it's silent:

  1. set bVirtualizeWhenSilent to true.

  2. In "Project Settings" -> "Engine" -> "Audio" -> "Quality", check "Allow Virtualized Sounds".

avatar image BlackFangTech Oct 07 '16 at 03:04 PM

This doesn't work for me.

With Allow Virtualized Sounds not checked, the sound starts playing when I enter the radius, but from the beginning instead of current video location.

With it checked, the sound doesn't play at all when I enter the attenuation radius.

avatar image quality Nov 04 '16 at 05:00 AM

So is there any way to fix this without C++. It is ridiculously annoying. I've got a VR level where you can walk up to a playing movie screen and walk away. Whenever you come back there's no sound.

avatar image gmpreussner STAFF Nov 04 '16 at 05:23 AM

Our audio programmer is currently on vacation. I think we'll have to make an adjustment to procedural sound waves in 4.15 for this to work properly.

avatar image quality Nov 04 '16 at 05:38 AM

Ok...I have to say I'm disappointed that this was ever considered something you could just turn off. Walking away from a sound (that is synced with video) and turning it off makes no sense, because when you start the sound again you'll have lost audio sync.

I guess you could try and play the sound at the right spot by getting the current location of the playing video and then trying to start the audio from that spot. Not sure if that would work, I haven't tried it.

For anyone struggling with this, the work around we found was to set a custom attenuation curve on an audio cue that never goes to zero. Our curve goes from 1 to 0.01 and the sound stays on (although not audible).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question