x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Error System Keychain on the remote Mac

Hi, Ok so im getting and error massage that says:

PackagingResults:Error: Error Failed to sign executable. Make sure your developer certificates have been installed in the System Keychain on the remote Mac.

So let me tell you what i have done. So i just restored my mac to factory start because i was having issues with it. So i reinstall xcode and add my dev account to it. I made new certificates and provision with .p12 as well. I then copied the certificates and key to the system in the System Keychain.

Then i put the new ones into the editor in unreal. So i followed all the steps and look up this issue in answerhub and im doing everything right. But when i go to package it i get this error. I cant seem to fix it so i need help. Hope you can help, Thank you for your time and have a nice day.

p.s here is the log to see.

link text

Product Version: UE 4.13
Tags:
log.txt (4.4 kB)
more ▼

asked Sep 19 '16 at 06:38 PM in Packaging & Deployment

avatar image

Snowynight
56 5 8 12

avatar image Samantha Sutton ♦♦ STAFF Nov 21 '16 at 05:01 PM

Snowynight,

Have you tried manually rebuilding iPhonePackager, DeploymentInterface and MobileDeviceInterface?

avatar image Snowynight Nov 21 '16 at 05:35 PM

Yes i have tried that still nothing get the same error.

avatar image Samantha Sutton ♦♦ STAFF Nov 22 '16 at 10:01 PM

Did you make sure to: PackagingResults:Error: Error Failed to sign executable. Make sure your developer certificates have been installed in the System Keychain on the remote Mac?

avatar image Snowynight Nov 22 '16 at 11:03 PM

I did put it in System Keychain. still have the same error.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Snowynight,

There is a known issue related to this. You can follow the progress of the issue as it moves through the developers, here:

https://issues.unrealengine.com/issue/UE-36149

There is also a couple more issues related to improving the remote building system as a whole.

There is a work around figured out by another user. You can follow it in this thread:

https://answers.unrealengine.com/questions/488680/remote-connection-to-mac-doesnt-work-on-413-and-io.html#answer-491610

more ▼

answered Sep 19 '16 at 07:02 PM

avatar image

ImVawx ♦♦ STAFF
6.8k 114 17 127

avatar image Snowynight Sep 19 '16 at 07:15 PM

Thank you, hope it gets fixed soon.

avatar image Snowynight Nov 14 '16 at 07:05 PM

Im still getting the same error.

avatar image Snowynight Nov 14 '16 at 07:07 PM
log.txt (8.5 kB)
avatar image Samantha Sutton ♦♦ STAFF Nov 23 '16 at 07:52 PM

Please make sure that you completed these steps to ensure you've set the Mac up properly to accept remote building:

  • Open the System Preferences > Sharing on the Mac machine

  • Check the Remote Login checkbox

  • Open System Preferences > Networking

  • Open Keychain Access

  • Select System from the left hand menu

  • Select Certificates from the left hand menu

  • Select one of the installed certificates

  • Right click on the certificate and select Get Info

  • Expand the Trust options

  • Set When using this certificate: to Always Trust (setting this will all of the sub options)

avatar image Snowynight Nov 23 '16 at 08:19 PM

Did every step, the only one that was not done prier what the Always Trust. Now it is set to always trust but im still getting the same error.

avatar image Samantha Sutton ♦♦ STAFF Nov 30 '16 at 07:11 PM

Have you upgraded to 4.14 yet, and tried the same steps there?

 UATHelper: Packaging (iOS): UnrealBuildTool: No signing certificate "iOS Development" found:  No "iOS Development" signing certificate matching team ID "BE2WVFER98" with a private key was found.
 UATHelper: Packaging (iOS): UnrealBuildTool: Code signing is required for product type 'Application' in SDK 'iOS 10.0'

Please double check that the certificates are installed on BOTH computers. Double check, it's very easy to mix up certificates, or forget to update them as necessary.

Make sure it's being signed for iOS development on the certificate as well. If you don't have one that matches, or one that isn't a wildcard, then you're going to run into trouble.

avatar image Snowynight Feb 07 '17 at 06:44 PM

Ok I'm slowly narrowing down the problem. Ok so when I use my ios development certificate and provisions ever thing works fine. But I can't submit it because you need to use distribution certificate and provisions for that.

So when I use the distribution ones that's where I get the problem. so i decided to see what the problem is because when I add the distribution ones in the unreal settings it gets add but I wanted to see if there is a problem so I used the IPhonePackager.

When I do that that were I see the problem when I try to add the distribution ones I get an error. Could not find file 'C:\Program Files\Epic Games\4.14\Engine\Build\IOS\UE4Game-Info.plist'.

When I look up that problem it says its a problem with the bundle info don't match but mine match they are the same I don't know that to do this problem has been going on for far too long.

avatar image Samantha Sutton ♦♦ STAFF Feb 08 '17 at 08:44 PM

It's been a while since we last spoke with you. Could you please upload screenshots showing your bundle ID matches? Which version of the engine are you working out currently?

Thank you!

avatar image Snowynight Feb 08 '17 at 09:07 PM

Ok here is a screen shot showing they match. I'm also working with 4.14.

[1]: /storage/temp/125459-bundle+id.jpg

bundle id.jpg (152.9 kB)
avatar image Samantha Sutton ♦♦ STAFF Feb 09 '17 at 03:52 PM

I believe you need to check which keychain is in your certificate on the mac, please review this AnswerHub post.

avatar image Snowynight Feb 09 '17 at 06:05 PM

I have seen that post before, that is not the problem I'm having. My problem is on the PC side of things. When using IPhonePackager to import my distribution certificate and provisions i get this error, "Could not find file 'C:\Program Files\Epic Games\4.14\Engine\Build\IOS\UE4Game-Info.plist".

avatar image Samantha Sutton ♦♦ STAFF Feb 13 '17 at 07:34 PM

Your key in the screenshot says Distribution while the error is saying Development. Are you positive that you're packaging your project under the correct settings? If you package for Development, you'll need Developmental provisions.

avatar image Snowynight Feb 13 '17 at 08:42 PM

I set it for Distribution. here is a screenshot of my project settings to show you.

[1]: /storage/temp/126131-sc.jpg

sc.jpg (904.0 kB)
avatar image Samantha Sutton ♦♦ STAFF Feb 14 '17 at 07:40 PM

If you have it set up for distribution and it's still calling development in the logs, make sure that you've deleted the Intermediate folder and Save folder and reset it to distribution and shipping. Make sure that the correct provisions and certificates are being used.

You might need to remove and reinstall your certificates and provisions for the engine. It's possible that the engine is picking up the wrong set.

Do you have any newer logs you can upload as a .txt file?

Thank you!

avatar image Snowynight Feb 14 '17 at 09:16 PM

Ok, so I deleted the Intermediate folder and Save folder from my project folder. I also delete the certificates in the AppData\Local\Apple Computer\MobileDevice\Provisioning Profiles. Don't know there to delete the provisions.

I then went to the IPhonePackager to reinstall the provisions and certificates and I'm still getting the same error here is the log from that.

avatar image Samantha Sutton ♦♦ STAFF Feb 14 '17 at 10:16 PM

Are you using a source version of the build? If so, I would recompile the whole engine to build for iOS. Let me know if it's a strictly blueprint project on a binary build.

avatar image Snowynight Feb 14 '17 at 11:31 PM

It is strictly blueprint project using the launcher version.

avatar image Samantha Sutton ♦♦ STAFF Feb 15 '17 at 09:37 PM

Snowynight,

I have submitted a Jira, which is not made public at this time. UE-42016 is the Jira relating to your issue specifically. If you have a project and/or certificates/provisions or any 100% reproduction steps you can provide, please do so in order to resolve this issue quicker.

Thank you for your patience.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question