x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

OS X Crashes, dark maps, and externally referenced assets

We're currently trying to open our project which we developed on Windows with a MacBook Pro (NVIDIA GeForce GT 750M, Mac OS X 10.11.6). The project is really dark in lit mode and it crashes regularly on specific actions (loading maps, building light, changing the rotation in viewport etc) with the following message:

 SEGV_MAPERR at 0x68
 
 FMetalContext::PrepareToDraw(unsigned int) Address = 0x1373c4f7d (filename not found) [in UE4Editor-MetalRHI.dylib]
 FMetalRHICommandContext::RHIDrawIndexedPrimitive(FRHIIndexBuffer, unsigned int, int, unsigned int, unsigned int, unsigned int, unsigned int, unsigned int) Address = 0x1373c77a4 (filename not found) [in UE4Editor-MetalRHI.dylib]
 FOcclusionQueryBatcher::Flush(FRHICommandListImmediate&) Address = 0x116733804 (filename not found) [in UE4Editor-Renderer.dylib]
 FDeferredShadingSceneRenderer::BeginOcclusionTests(FRHICommandListImmediate&, bool) Address = 0x11673a0a6 (filename not found) [in UE4Editor-Renderer.dylib]
 FDeferredShadingSceneRenderer::RenderOcclusion(FRHICommandListImmediate&, bool, bool) Address = 0x11615d686 (filename not found) [in UE4Editor-Renderer.dylib]
 FDeferredShadingSceneRenderer::Render(FRHICommandListImmediate&) Address = 0x11616585f (filename not found) [in UE4Editor-Renderer.dylib]
 FRendererModule::BeginRenderingViewFamily(FCanvas, FSceneViewFamily)::EURCMacro_FDrawSceneCommand::DoTask(ENamedThreads::Type, TRefCountPtr<FGraphEvent> const&) Address = 0x11674d7f3 (filename not found) [in UE4Editor-Renderer.dylib]
 TGraphTask<FRendererModule::BeginRenderingViewFamily(FCanvas, FSceneViewFamily)::EURCMacro_FDrawSceneCommand>::ExecuteTask(TArray<FBaseGraphTask, FDefaultAllocator>&, ENamedThreads::Type) Address = 0x11678000b (filename not found) [in UE4Editor-Renderer.dylib]
 FNamedTaskThread::ProcessTasksNamedThread(int, bool) Address = 0x107792810 (filename not found) [in UE4Editor-Core.dylib]
 FNamedTaskThread::ProcessTasksUntilQuit(int) Address = 0x10778e215 (filename not found) [in UE4Editor-Core.dylib]
 FTaskGraphImplementation::ProcessThreadUntilRequestReturn(ENamedThreads::Type) Address = 0x10778a7d1 (filename not found) [in UE4Editor-Core.dylib]
 RenderingThreadMain(FEvent) Address = 0x10e2a4fd4 (filename not found) [in UE4Editor-RenderCore.dylib]
 FRenderingThread::Run() Address = 0x10e2bbb17 (filename not found) [in UE4Editor-RenderCore.dylib]
 FRunnableThreadPThread::Run() Address = 0x1077e2328 (filename not found) [in UE4Editor-Core.dylib]
 FRunnableThreadPThread::_ThreadProc(void) Address = 0x1077a4371 (filename not found) [in UE4Editor-Core.dylib]
 _pthread_body Address = 0x7fff9890599d (filename not found) [in libsystem_pthread.dylib]
 _pthread_body Address = 0x7fff9890591a (filename not found) [in libsystem_pthread.dylib]
 thread_start Address = 0x7fff98903351 (filename not found) [in libsystem_pthread.dylib]

We tried renaming the project folder and removing the folders "Saved", "Intermediate", "Build" and "Binaries" but it didn't fix the issues.

Saving maps opens a message box with:

This map is using externally referenced packages which won't be found when in a game and all references will be broken. Perform a map check for more details.

Would you like to continue?

Running a map check prints these warnings (a lot more of them):

 MapCheck:Warning: Warning EdGraphPin_2283 EdGraphPin /Game/Maps/World/World.World:PersistentLevel.World.EventGraph.K2Node_CallFunction_15688.EdGraphPin_2283 : Externally referenced 
 MapCheck:Warning: Warning EdGraphPin_2298 EdGraphPin /Game/Maps/World/World.World:PersistentLevel.World.EventGraph.K2Node_CallFunction_15690.EdGraphPin_2298 : Externally referenced 
 MapCheck:Warning: Warning EdGraphPin_2313 EdGraphPin /Game/Maps/World/World.World:PersistentLevel.World.EventGraph.K2Node_CallFunction_16857.EdGraphPin_2313 : Externally referenced 
 MapCheck:Warning: Warning EdGraphPin_2328 EdGraphPin /Game/Maps/World/World.World:PersistentLevel.World.EventGraph.K2Node_CallFunction_16859.EdGraphPin_2328 : Externally referenced 
 MapCheck:Warning: Warning EdGraphPin_2343 EdGraphPin /Game/Maps/World/World.World:PersistentLevel.World.EventGraph.K2Node_CallFunction_16861.EdGraphPin_2343 : Externally referenced 
 MapCheck:Warning: Warning EdGraphPin_2358 EdGraphPin /Game/Maps/World/World.World:PersistentLevel.World.EventGraph.K2Node_CallFunction_16099.EdGraphPin_2358 : Externally referenced 
 MapCheck:Warning: Warning EdGraphPin_2373 EdGraphPin /Game/Maps/World/World.World:PersistentLevel.World.EventGraph.K2Node_CallFunction_15692.EdGraphPin_2373 : Externally referenced 
 MapCheck:Warning: Warning EdGraphPin_2388 EdGraphPin /Game/Maps/World/World.World:PersistentLevel.World.EventGraph.K2Node_CallFunction_15694.EdGraphPin_2388 : Externally referenced

These map check warnings are unique to the project running on the MacBook Pro.

Product Version: UE 4.12
Tags:
more ▼

asked Sep 19 '16 at 11:14 PM in Using UE4

avatar image

Reisn7CC
20 4 5 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Reisn7CC,

Whether you created a Windows project on a Mac, or vice versa, you can more than likely expect there to be issues like the one you are experiencing. If you are moving from Windows to Mac then the externally referenced issues are definitely expected.

This is unfortunately not a bug, but the outcome following the workflow you are using. Mac's use a different Shader Model and API so moving across platforms with those settings in tact is going to cause errors.

Config settings within the Engine and Project are going to conflict one another since you started on Windows and moved to a Mac. The only thing you can do in this case is to go one by one and locate the source of the externally referenced nodes and systematically resolve them.

If you have further questions let me know.

Cheers,

Andrew Hurley

more ▼

answered Sep 20 '16 at 03:48 PM

avatar image Panelsofsilence Sep 23 '16 at 10:07 AM

This is a huge issue... To sad there isn't a tool that help us locating and resolving the source of the externally referenced nodes, in the continuity of the map check.

avatar image AndrewHurley Sep 23 '16 at 02:28 PM

There is actually a tool to find out how and where your assets are referencing others.

Reference Viewer - Tool

alt text

Right-click on an asset in your content browser to view where it is being referenced.

Cheers,

Andrew Hurley

referenceviewer.png (654.5 kB)
avatar image Panelsofsilence Oct 06 '16 at 08:40 AM

Hi Andrew,

I am encountering this same externally referenced issue, because I am developing my project both on Mac and PC. So I looked to the reference viewer tool, but there the asset that is supposed to be externally referenced look OK : alt text

How am I suppose to manually correct this externally referenced error?

avatar image AndrewHurley Oct 06 '16 at 03:18 PM

Unfortunately, this error can be caused by in a number of ways and there is not any one fix for the issue.

Take a read over the post below to get an idea of how your errors are appearing and what you can do to fix the issue.

https://answers.unrealengine.com/questions/305244/externally-referenced-warning-what-does-it-mean.html

Hopefully you can derive a fix from the suggested fixes on the post, but let me know if you have further questions.

Thank you,

Andrew Hurley

avatar image Panelsofsilence Oct 07 '16 at 08:18 AM

Thanks Andrew, The problem in the post you mentioned, and all the post I found on the anwserhub, is that the only fix they mention is basically to rename the folder of the project. Which as far as I am concerned doesn't work anymore. Do you know other fix that could work? (or is the issue just related to the name of the path?)

avatar image AndrewHurley Oct 07 '16 at 02:28 PM

So the only other suggestion that I know of that could resolve the Externally Referenced issue which was mentioned as the last comment on the post I linked.

"Try deleting your 'Saved' folder in your project files. This worked for me after the rename trick failed, likely because I copied my whole project from another computer, and then upgraded to a newer version."

Hopefully that can do the trick, but let me know if you are still in need of assistance.

Cheers,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question