x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Particle shadow disappears with distance

Hi guys, I have a particle system for rocket smoke and I wanna see them from little far but after a point shadow disappears my material is translucent default lit here ss

alt text

[1]: /storage/temp/107940-1.png

Product Version: UE 4.12
Tags:
1.png (688.5 kB)
2.png (680.9 kB)
more ▼

asked Sep 21 '16 at 10:44 AM in Rendering

avatar image

ismail.bulbul
63 1 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi ismail.bulbul,

Open console commands by pressing the ~ key and type r.Shadow.FadeResolution 32 to see if that resolves your issue. How this command works is it uses this value to determine at what size on screen will the shadow start fading out. The lower the number the smaller the shadow has to be on screen before it fades out. Be careful as this will affect performance.

Let me know if that helps

Ed Burgess

more ▼

answered Sep 21 '16 at 09:03 PM

avatar image ismail.bulbul Sep 22 '16 at 08:16 AM

No,it didnt solve my problem. I also tried solutions in this link but they also didnt work for me

https://answers.unrealengine.com/questions/60734/shadows-fading-out-with-increased-camera-distance.html

When I change material type from translucent to opaque it fixes my problem but I need translucent. I am using M_smoke_subUV material from contents

avatar image Ed Burgess ♦♦ STAFF Sep 22 '16 at 01:12 PM

This could be a number of things. Just to be sure here is a list of troubleshooting steps:

  • look at your light and make sure cast translucent shadows is checked and also look at the particle system and make sure cast shadow along with Volumentric Translucent Shadows is checked.

  • Open your particle system and click on Bounds at the top in the toolbar. Then click set fixed bounds. In the particle's general settings you can make the fixed bounds size larger to make sure this isn't a bounds issue.

Also, could you upload a screenshot of your material graph for the particle in question and a screenshot of the particle system settings (just click in the black area out side of the modules for the details panel to display the general settings.)

avatar image ismail.bulbul Sep 23 '16 at 08:10 AM

lights cast translucent shadows is checked but I cant find cast shadow along with Volumentric Translucent Shadows option

Particle bounds are ok.

Still problem occurs

alt text

alt text

alt text

alt text

alt text

3.png (366.4 kB)
4.png (34.6 kB)
5.png (39.1 kB)
6.png (48.4 kB)
7.png (222.2 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi ismail,

After seeing your material graph I can determine that your issue is the depth fade node. There is a known issue where using depth fade removes lit particles translucent shadows! https://issues.unrealengine.com/issue/UE-24249

I've updated the bug to say that this is still a problem in 4.13

Thanks,

Ed Burgess

more ▼

answered Sep 23 '16 at 01:53 PM

avatar image ismail.bulbul Sep 26 '16 at 06:57 AM

Hi Ed, thank you for your time,

How can I create smoke particles which can cast shadow with increased distances. If you have any example could you please share with me ?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question