x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

3D Widget not visible in editor 4.13

Hello, I've just moved my project over from 4.12 to 4.13. I've been using 3D Widgets as a sort of pop up sign to show when the player is near to something they can interact with.

It all works in 4.12 but now I've moved over to 4.13 the 3D Widgets don't show in the editor window. They work fine when playing in the editor window. It's making setting them up in the right places far more long winded than it used to be.

So far I've tried making a new widget from scratch and recompiling the game in Visual Studio.

Product Version: UE 4.13
Tags:
more ▼

asked Sep 22 '16 at 09:19 AM in Bug Reports

avatar image

Jazz
86 3 8 27

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

This is very strange, I just checked the "Show FPS" box in the editor window and now the 3D Widgets are visible.

more ▼

answered Sep 22 '16 at 10:46 AM

avatar image

Jazz
86 3 8 27

avatar image Rudy Q ♦♦ STAFF Sep 22 '16 at 01:10 PM

Hello Jazz,

I am happy to hear that you were able to resolve your issue. I will be converting your last comment to an answer. If this issue occurs again please feel free to reopen this issue with any additional information on how to reproduce this issue in a clean project and I will be more than happy to help.

Make it a great day

avatar image NiekPixelpool Sep 28 '16 at 12:07 PM

I Just experienced the same issue with exact the same fix. Could this be a 4.13 bug?

avatar image ecosky-oculus Feb 09 '17 at 10:47 PM

I had the same problem and surprisingly toggling the Show FPS caused the widgets to appear again. This is with UE 4.14.3.

avatar image Han.Vicon Apr 04 '17 at 01:59 PM

Still the case on 4.15.1

avatar image KingOfHz May 29 '17 at 02:43 PM

Still the case in 4.15.3

avatar image mirrorlink Jul 03 '17 at 06:49 PM

Thanks @Jazz, solved my issue.

avatar image nikita.khudiakov Aug 09 '18 at 12:25 PM

Still the case in 4.19

avatar image RapidBlaze Nov 26 '18 at 03:29 PM

Still the case in 4.20.3. Jazz's solution completely works

avatar image tmcraig08 Dec 18 '18 at 04:20 PM

in 4.20 i had to tick Draw at Desired Size, within the widget actor

avatar image NathanVMP Feb 04 '19 at 02:09 PM

Still the case in 4.21

avatar image stefandup May 23 '19 at 08:11 PM

Still the case in 4.22 (facepalm)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question