x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

PackagingResults Error Unknown

Hi, im getting the following output error when trying to package my game. It was working fine then just recently I noticed it told me I did not have Visual Studio installed (which surely it must have been as its packaged fine before). I installed it and still had no luck. Then have tried completely reinstalling both Unreal 4 and Visual Studio when prompted. What's the issue and how do I rectify it?

I'm also on Windows 10 6 4bit and have made sure common tools is installed during the installation.

Thanks a lot,

Samlink text

Product Version: UE 4.12
Tags:
output log.txt (22.8 kB)
more ▼

asked Sep 22 '16 at 12:57 PM in Packaging & Deployment

avatar image

HomeGrownHeroz
21 4 8 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello HomeGrownHeroz,

From looking at this log, it seems that there are two error messages that are the main culprits:

 MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: ERROR: Windows SDK v8.1 must be installed in order to build this target.
 
 MainFrameActions: Packaging (Windows (64-bit)): WindowsPlatform.get_Compiler: WARNING: Visual C++ 2015 toolchain does not appear to be correctly installed. Please verify that "Common Tools for Visual C++ 2015" was selected when installing Visual Studio 2015.

For the first one, could you download the Windows SDK v8.1 and install that to see if it will fix this issue? You can find that on Microsoft's website here.

For the second one, please open Control Panel > Programs & Features > Microsoft Visual Studio 2013 and select Change/Modify. Once the installer comes up, select "Modify" and you'll see a list of options. Please select "Common Tools for Visual C++ 2015" under the Programming Languages > Visual C++ section and then press Update. This'll add the necessary components.

more ▼

answered Sep 22 '16 at 03:28 PM

avatar image HomeGrownHeroz Sep 22 '16 at 03:47 PM

Thanks for the suggestions. Common tools is already installed but I noticed I have Visual Studio Community 2015 with Updates installed, not 2013. Does that make a difference? It was the link that I was presented with inside Ue4 when I tried to package the game.

I have also installed the SDK from the link provided but had no luck. I've attached another log file.

Thanks again for your help.link text

output log 2.txt (20.3 kB)
avatar image Matthew J Sep 22 '16 at 03:58 PM

That was a mistype on my part, It should be 2015. Also please be aware that there are multiple entries listed as "Common Tools" but they are different and the "Common Tools for Visual C++ 2015" is the one you need. That message is still present meaning that it isn't installed.

avatar image HomeGrownHeroz Sep 22 '16 at 04:53 PM

Awesome! That did the trick. Thanks so much :)

Do you know what could have caused this issue when it was working before then?

If these tools are necessary for the packaging to work properly, then should Unreal install them during the initial setup?

Cheers again!

avatar image Matthew J Sep 22 '16 at 04:57 PM

What is decided with the initial setup for Visual Studio is in Microsoft's hands, not ours unfortunately. We only provide the installation package which is provided by Microsoft.

The most common reason it stopped working without Visual Studio, since I'm assuming you didn't add any code to the project yourself, is that you added or activated a plugin that needs to be compiled upon packaging, which isn't possible without Visual Studio installed.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question