x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging Failed (unknown cook failure)

I'm having problems packaging my project. For some reason it won't package. I've tried packaging in development and shipping and always fails.

  • packaging for windows 64 bit

  • UE 4.10

  • blueprint project

I've read that the level may be too big as it says: MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: FMemoryWriter does not support data larger than 2GB. Archive name: E:/Work Folder/Unreal Projects/Shutter/Content/StarterContent/Maps/Minimal_Default.umap.

Some posts suggest level streaming and splitting up the level in areas. Would that work?

Also read that sometimes the lighmap might be too big. I'm setting the build quality to preview and trying again, see what happens. In the mean time i'm leaving a copy of my build log. If anyone can help me find the problem here, i'd be very grateful. I spent three months working on this and I really don't wan to scrap it because UE refuses to build. There's a lot of hard work involved in this :\

Thanks.

link text

Product Version: UE 4.10
Tags:
build failed.txt (285.7 kB)
more ▼

asked Sep 22 '16 at 10:33 PM in Packaging & Deployment

avatar image

Bad_Request
1 1 2

avatar image Bad_Request Sep 22 '16 at 10:36 PM

Forgot to mention the game works fine in the editor. I've also migrated only the maps i needed from the original project to a blank project and re-configured it to reduce size. It was also working fine in the editor. Tried compiling both the original project and the "clean" project and they both fail.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I managed to solve the problem. By splitting the level into three sections and level streaming each part accordingly seemed to solve the build problem. I also had an icon there that was corrupted. At least it builds, but now i have to deal with a number of bugs that never happened before i split the level.

more ▼

answered Sep 23 '16 at 01:10 PM

avatar image

Bad_Request
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question