x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Issues with launch on ios (ue 4.13)

I have been working on a project for a while now, which I regularly run on ios to make sure everything is working. Since the project is "blueprint" only I have had no need for a mac to compile with, and the launch and build processes have been working very well for me.

I upped the project version to 4.13 the other day, and now when I try to launch on ios I get errors about missing parameters for remote compilation. But I don't want to compile remotely(yet) since the project is blueprint only.

Did the option to run without a Mac go away on BP only projects with the new remote compile in 4.13?

Product Version: UE 4.13
Tags:
more ▼

asked Sep 23 '16 at 01:22 PM in Packaging & Deployment

avatar image

Postalh
66 3 8 10

avatar image Steve Hardister ♦♦ STAFF Sep 23 '16 at 02:15 PM

Hi PwnPwn,

You should still be able to Launch on and package for iOS with an All-Blueprints projects on Windows; This has not changed. When you updated to 4.13 did you save a copy in the previous version? Was the previous version 4.12? Please provide this information, along with your latest output log and screenshots of your package and iOS settings from your Project Settings.

Thanks,

Steve H.

avatar image Postalh Sep 26 '16 at 02:54 PM

Hi!

I have attached the latest log output, which is what I can when I try to launch on ios. I upgraded from 4.12. I tried rolling back to the old version and it still works. No settings changed when going to 4.13. alt text

alt text

log.txt (17.0 kB)
ios settings 1.png (200.7 kB)
ios settings 2.png (226.8 kB)
avatar image Steve Hardister ♦♦ STAFF Sep 27 '16 at 03:56 PM

A few more questions and steps to try (For the UE4.13 version):

  1. Where are you seeing errors about missing parameters for remote compilation... In the output log?

  2. Please post the output log as a text file

  3. Have you tried packaging for Development (for debugging?) Try launching on the iOS device with this setting and post the output log if it fails.

  4. Your Remote Build options aren't exposed in the supplied image; Make sure none of these are selected/set up for remote build.

avatar image Postalh Sep 28 '16 at 08:04 AM

It doesn't say missing parameters, but:

LogPlayLevel: UnrealBuildTool: Picking the default remote server LogPlayLevel: UnrealBuildTool: Remote compiling requires a server name. Use the editor (Project Settings, IOS) to set up your remote compilation settings. LogPlayLevel: UnrealBuildTool: Doing xcode-select --print-path LogPlayLevel: UnrealBuildTool: ERROR: Failed to start local process for action ("Cannot start process because a file name has not been provided.")

"File name has not been provided", that is what I was referring to.

I did attach it as a text file, or how do you mean?

I tried for development, same issue. No remote build settings are selected or setup.

avatar image Steve Hardister ♦♦ STAFF Sep 28 '16 at 03:48 PM

Sorry, I missed your log as it appeared directly under the image. Comparing another user with a similar issue on this post:

Launch/Build on iOS failed to install

...Please check to make sure the Bundle ID in your project settings matches the Bundle ID for certificate and provision you are using to Launch on to the iOS device. You will need to sign into your Apple Developer's account to check this.

Beyond this answer, we typically see this error when people are using the Github/Source version of the editor. Please verify that you are using the Launcher/Binary version of UE4.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi PwnPwn,

Since we have not heard back from you in a while, we are marking this post "resolved" for tracking purposes. However, if you are continuing to have problems launching on to an iOS device, please respond with the requested information and we will continue to investigate.

Thanks,

Steve H.

more ▼

answered Oct 03 '16 at 01:47 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question