Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

All materials are blurred in imported meshes

Hi there. First time poster here and new user to UE4. loving it so far, though admittedly frustrated.

So I have attached a photo of a scene i am working on. The geometry I created in Rhino 5, exported to 3dsmax, and then exported into UE4 via FBX. (When i tried rhino into Ue4 it would always hang at 75%).

Anyway, when I add materials to my mesh sections, it comes up blurry every time. Is this a UV mapping issue? I am terribly confused, because when I drop in a cube from the UE4 basic tab, or a bsp brush, and add the same material, it comes up fine, as a plank of wood for example.. Though it happens with all materials. The brown section below the point light is the same material applied.

The rest of the materials in the scene are from the automotive materials pack.

Any solution to this? Am I importing incorrectly perhaps?

alt text

Product Version: UE 4.13
problem 1.jpg (79.9 kB)
more ▼

asked Sep 24 '16 at 10:25 PM in Rendering

avatar image

1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

try importing as an obj I usually have an easier time getting my assets into UE4 that way but if that doesn't work and you're still getting the same problem your uv's are messed up maybe upload a couple images of your uvs and the meshes you're trying to apply this material too. try the OBJ import and if that doesn't work post a picture of your uv's and wire frame.

more ▼

answered Sep 25 '16 at 07:23 AM

avatar image

the real pariah
7 2 3 8

avatar image obi_ido Sep 25 '16 at 09:24 PM

Thanks for the reply! I have tried importing an OBJ, same results unforutately.

I've included a pic of the wireframe, but how do i show you the UV's?

Apologies if thats a dumb question

alt text

problem 3.jpg (252.0 kB)
avatar image the real pariah Sep 26 '16 at 12:48 PM

It's most definitely a uv problem your uv's may be inversed or the mesh you're using doesn't match your uv map. Open your mesh in max and open your uv editor and take a screen shot then also send screen shots of any maps you're using(Normals, AO, Rough/Spec, Color). I've had this happen to a mesh before where I changed my pivot point and didn't redo my uv's could be a really simple fix will know more once you get the screen shots. On the bright side your geo is really nice!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This explains it all: http://bfy.tw/7url

more ▼

answered Sep 27 '16 at 10:28 PM

avatar image

9.3k 286 65 332

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question