x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why is the base color making my material seem emissive?

Edited: for better clarification.

I've built a double door that opens and closes using blueprints. When I add my base color to the material it brightens it, as if it has an emissive property applied which it does not.

The images I've attached show the incorrectly lit door in nearly total darkness, but as you can see the walls, door frame, and terminal all are in the darkness, but the doors themselves are bright. The second image I set the scene to unlit to better see the problem.

I've been trying to solve this on my own, and searching the net for a couple days, and at this point any help would be amazing. Thanks!!

alt text alt text

Product Version: UE 4.11
Tags:
more ▼

asked Sep 25 '16 at 07:28 PM in Using UE4

avatar image

mikegarn
22 4 5 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Found this solution for another problem, but I'm pretty sure its the solution here too:

Settings (Bar near the top of the editor) > World Settings > Lightmass > Lightmass Settings > Environment Intensity=0

Link to where I found the solution: https://answers.unrealengine.com/questions/27431/cannot-for-the-life-of-me-make-a-completely-dark-m.html

more ▼

answered Jan 20 '18 at 04:35 PM

avatar image

mikegarn
22 4 5 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I don't think it's your material, Unreal has a feature called Eye Adaptation that is enabled by default:

https://docs.unrealengine.com/latest/INT/Engine/Rendering/PostProcessEffects/AutomaticExposure/

Once you applied your material, the engine automatically adjusted the exposure of the image. You might have noticed a small fade-in/fade-out when you lookaway of the door. To fix this, either turn off eye adaption in the post process effect or the viewport settings, or build a consistent lighting setup.

more ▼

answered Sep 25 '16 at 08:36 PM

avatar image

Night Watcher
1.7k 44 12 71

avatar image mikegarn Sep 25 '16 at 09:44 PM

Thank you for the advise. Unfortunately the solution does not involve eye adaptation. The problem does not apply to the entire scene, but only to this particular mesh and when any texture (including vector parameters) are applied to the base color of the material.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Ok I kinda found the problem. The Skylight was casting light onto only certain meshes through the walls. I don't know the specifics yet but I deleted the skylight and now all the shadows are correct.

more ▼

answered Sep 26 '16 at 01:01 AM

avatar image

mikegarn
22 4 5 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question