x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Detach From Actor doesn't work.

alt textHello people.

I'vebeen trying to use a simple attach and detach script but it doesn't want to work. As you can see in the image, i attach my player to an actor. then when i press space (or in this case my actionmapping) i want it to detach. But it doesn't. It plays the "hello" print string but it doesn't detach. BUT, if i add the delay function, it DOES actually detach after the delay is finished! Is this a bug or does Unreal not support DetachFromActor with Input events?

Thanks //Edwin

Product Version: UE 4.13
Tags:
more ▼

asked Sep 26 '16 at 04:34 PM in Blueprint Scripting

avatar image

Aceswe
11 1 1 2

avatar image Benebot Oct 01 '17 at 04:14 PM

Hi Edwin,

I have done it but with all rules ( in AttachToActor and in DetachFromActor) set to world, and it works for me.

Cheers, Carlos

avatar image poke1103 Sep 01 '18 at 06:18 PM

This does not work. I repeat, the OP is right. It is a broken feature in 4.20.2

avatar image Blastertoad Oct 25 '18 at 02:24 AM

Same issue in 4.20.3

avatar image Slavq Nov 07 '18 at 04:52 PM

I also have this issue in 4.20.3. Is this bug reported already? If not, I can make a report for that.

avatar image Slavq Nov 07 '18 at 05:15 PM

... It looks like the detach doesn't work if it's called from ConstructionScript. If called from e.g. a function with CallInEditor, it woks ok. I'm trying to reproduce that cleanly now.

avatar image Slavq Nov 07 '18 at 05:18 PM

It also doesn't work in 4.19, maybe in the earlier versions too. DetachFromActor doesn't work when called from ConstructionScript, but works when e.g. called from a function with Call In Editor (button).

avatar image Slavq Nov 07 '18 at 05:22 PM

... Looks like it's an UE limitation, I've found related issue, with the same suggested workaround here: https://answers.unrealengine.com/questions/453628/get-attached-actors-doesnt-run-in-construction-scr.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question