x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Emissive for static lighting not working if static shadow is off?

Hello. I am creating a custom actor for emissive static lighting and I'm quite happy with the result. Yet, I have noticed a strange behavior: in order to have the emissive baked in the lightmass, the mesh must have static shadows on. Is this intended?

To reproduce this just create a mesh with a strong emissive material, set it to static, turn on Emissive For Static Lighting in the mesh lightmass settings, bake, then turn off the static shadow on the mesh and bake again. You should notice that without the static shadows the emissive is not considered by the lightmass.

Product Version: UE 4.13
Tags:
more ▼

asked Sep 27 '16 at 04:07 PM in Rendering

avatar image

Snowbro
54 18 11 15

avatar image Snowbro Sep 27 '16 at 04:14 PM

I tried different solutions: setting the material to translucent, using some opacity mask in the lightmass replace, none seems to be working: if the mesh doesn't cast a static shadow, it won't feed her emissive to the lightmass.

EDIT: The only way to achieve what I seek, currently, is using planes so that they are only rendered on the side that won't receive lighting. Very limitating, still investigating!

EDIT2: Turning on "shadow indirect only" seems to remove at least the main static shadow. Still not an ideal solution but we're getting closer!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question