x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4 Doesn't package nor launch html5

Hello,

Recently I have decided on trying to move one of my projects to HTML5, so that it can be used on our company site. Before doing anything more I just did a new project, blank blueprint /w starter, removed the chairs and setup a basic box for a floor.

When packaging, both /w and without the chairs, table, etc. after waiting for 5-10 minutes it finishes and in the designated folder I can see a HTML5 subfolder created, but no files whatsoever, 0bytes.

I also tried launching it. Didn't work, here's the log. Both packaging and launching got me unknown errors. Version: Standard 4.11.2 /w editing symbols.

Thank you, Bonorose


link text

Product Version: UE 4.11
Tags:
output log.txt (528.0 kB)
more ▼

asked Sep 28 '16 at 08:16 AM in Packaging & Deployment

avatar image

Bonorose
6 1 2 3

avatar image Samantha Sutton ♦♦ STAFF Sep 28 '16 at 09:25 PM

Bonorose,

 LogPlayLevel: CommandEnvironment.SetupBuildEnvironment: WARNING: ERROR: NOTE: Please ensure that 64bit Tools are installed with DevStudio - there is usually an option to install these during install
 LogPlayLevel: CommandEnvironment.SetupBuildEnvironment: WARNING: Assuming no compilation capability.

This sounds like an issue we saw quite a few version ago. Please check out this AnswerHub post and see whether or not the suggestion fixes the issue.

If that does not work, install 4.12.5 or 4.13 and see if you're still having HTML5 complications.

Thank you!

avatar image Bonorose Sep 30 '16 at 07:56 AM

Hello Samantha,

I did change the version to 4.13.1 and remade the project. Started the packaging, it finished, no errors this time.

However, the designated folder is still empty excluding the "HTML5" folder that was created ( Still all is 0bytes)

avatar image Rumiko Hoshino STAFF Oct 05 '16 at 03:55 AM

Hello Bonorose,

I think this part of your original error log looks similar to UE-36717 error log I saw:

 LogPlayLevel: HTML5Platform.Package: Setting Emscripten SDK for packaging..
 LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception: System.IO.FileNotFoundException: Could not find file 'D:\Epic Games\4.11\Engine\Intermediate\Build\HTML5\.emscripten'.

Do you happen to have HOME environment variable on your PC? That seems to make Html5 packaging fail(in 4.11 and later), so if you have HOME env var, could you test if deleting the env var make a difference?

https://issues.unrealengine.com/issue/UE-36717

avatar image Bonorose Oct 10 '16 at 04:59 AM

Hello, I do not know, I checked and the error really was from the .emscripten and so on. Could you still explain about the HOME var ? I don't think I have. I installed a clean 4.13.1 on my other PC and managed to pack it there.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi, you can check what environment variables are defined for your pc in:

Windows Control Panel > System > Advanced system settings > Environment Variables

Or running "set" command in command prompt.

So far it seems HOME or EM_CONFIG environment variables can cause .emscripten not found error. In that case, .emscripten folder gets created in HOME or EM_CONFIG folder - which is not 'D:\Epic Games\4.11\Engine\Intermediate\Build\HTML5.emscripten' - then there will be .emscripten not found error.

Well, if you do not have HOME nor EM_CONFIG, then the cause would be different...

more ▼

answered Oct 11 '16 at 10:00 AM

avatar image

Rumiko Hoshino STAFF
263 7 5 15

avatar image Bonorose Oct 11 '16 at 03:34 PM

Hello,

Yes, I do have HOME under user var.

After deleting it I made a new project, compiled, it worked. No error, all exported. So yeah, HOME was the reason. Thanks for your help !

avatar image Rumiko Hoshino STAFF Mar 21 '17 at 02:18 AM

HTML5 packaging issue with HOME env var is now fixed - the fix will be in 4.16.

https://issues.unrealengine.com/issue/UE-36717

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question