x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

CineCameraActor Tick isn't firing

Hello,

I am not sure if this is a bug but for some reason when creating a CineCameraActor and putting a PrintString in the event tick, I am not getting any debug output to the screen when I play the level. Creating a regular CameraActor in the same way will output the default Hello text.

alt text

Has any one run into this and is there anything else I could check to resolve this issue?

Thanks in advance.

Product Version: UE 4.13
Tags:
capture.png (43.5 kB)
more ▼

asked Sep 28 '16 at 07:25 PM in Bug Reports

avatar image

renardmf
11 1 6

avatar image mamoniem Sep 28 '16 at 09:59 PM

Just remove the green line (DeltaSeconds->Duration). And make sure to drag and drop the blueprint into the level.

-m

avatar image mamoniem Sep 28 '16 at 10:01 PM

After removing the connection, keep in mind that Duration will need to have a value that is not 0

-m

avatar image renardmf Sep 28 '16 at 10:10 PM

Okay, removing the duration connection and setting it back to 2 allowed it to show one instance of the "Hello" Text but it should be showing a constant stream of text which seems to work as intended with just a regular CameraActor Blueprint. This was actually just a small test of another issue I was having with a blueprint that was parented by the CineCameraActor class. It didn't seem like the Tick was working correctly.

avatar image mamoniem Sep 28 '16 at 10:23 PM

I just tried it, and yes it does exactly the same as you mentioned. It is even worst, as it does the same thing at 4.12 :/

-m

avatar image AndrewHurley Sep 29 '16 at 02:32 PM

Hey renardmf,

I just tested adding a cine cam actor and calling the default 'Hello' text through a Print String via the Level Blueprint, and did not get the same results. If you connect delta seconds to the duration, it will only print out a single line of text as it is the same as leaving the duration at 0.0.

If you set it to something like 5.0 the default 'Hello' should scroll through the screen as expected. Can you provide me with some screenshots or simple steps to make sure we are following the same process?

Thank you,

Andrew Hurley

avatar image renardmf Sep 29 '16 at 05:54 PM

Hello Andrew,

As mentioned in the thread above I have since tried it without the delta time connection and just used implicit values like 2 and 5 with the same results. The CineCameraActor is only outputting "Hello" once and the regular CameraActor is outputting the expected stream of "Hello"s. I have attached screenshots of the setups for both actors which should be identical. The two blueprints were created by using the blue "Blueprint/Add Script" button on both of the actors. I am using UE 4.13.0.

Let me know if you need an additional information.

Thanks.

alt text alt text

cinecamera.png (1.3 MB)
cameraactor.png (1.2 MB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Thanks for the clarification and the screenshots as requested. I was able to confirm what you are reporting and have gone ahead and entered a bug report for the issue. You can track the issue following the link below on our new Public Issues Tracker.

UE-36625

Once the issue has been addressed by our engineers, the fix will be added to the release notes for fixed issues within an upcoming full engine or hotfix release.

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

more ▼

answered Sep 29 '16 at 06:54 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question