x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.13 Startup Movies Broken on Mobile Shipping Builds

I am not able to get my startup movie to work on Shipping builds on both Android and iOS. The startup movie plays and I hear audio, but all I see rendered is a default checkerboard pattern.

When I package in Development, the video works fine.

I've tried several different video formats and all are yielding the same results so far.

Has anyone gotten Startup Movies to work on Shipping builds using 4.13?

Product Version: UE 4.13
Tags:
more ▼

asked Sep 28 '16 at 11:51 PM in Packaging & Deployment

avatar image

NeoRob.gg
66 1 5 12

avatar image Samantha Sutton ♦♦ STAFF Sep 29 '16 at 05:25 PM

NeoRob.gg,

I am using 4.13.1 and I am not having any trouble with shipping builds.

  • What types of devices are you using exactly?

  • What is the version of the iOS and Android are you on?

Thanks!

avatar image NeoRob.gg Sep 29 '16 at 09:41 PM

It was on a several different devices: iPhone 6, Samsung S7, S4, and a Nexus. I don't have the version numbers at the moment.

What's the format of the video you are testing with?

I will be trying 4.13.1 to see if that fixes it.

avatar image NeoRob.gg Sep 30 '16 at 06:21 PM

I've tried on 4.13.1 and the video is still not working on a Shipping build but works on Development.

I suppose the next thing I will try is on a fresh template project.

avatar image NeoRob.gg Sep 30 '16 at 11:00 PM

I tried creating a new project and the startup video is working with that one. I am at a loss as to why it isn't working on my original project...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

NeoRob.gg,

I'm glad that a new project did not show the same movie complications as your original project did. It's possible that your project being created in an older version of the engine could have caused an issue? Or it could be part of your blueprint set up, or code? I would suggest migrating your project to the new project that's working and see if that resolves your issue.

Thank you!

more ▼

answered Oct 06 '16 at 05:53 PM

avatar image NeoRob.gg Oct 06 '16 at 06:10 PM

I tracked it down to a couple blacklist lines I was using to get the package size smaller.

  • ../../../Engine/Content/Slate/Fonts

  • ../../../Engine/Content/EditorMeshes/ColorCalibrator

I'm not sure which of these was breaking it, but the first wasn't even the cooked directory. I had copied these from an earlier project. It's strange that blacklisting the second would have had any effect on the video.

We have since given up on making the package extremely small anyway, so I just removed them and now it's working.

avatar image Samantha Sutton ♦♦ STAFF Oct 11 '16 at 09:48 PM

Thanks for pointing out that the blacklist was causing an issue. UE-37190 has been put in place for this issue.

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question