x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Sequencer Batch Rendering not working

Hey everyone,

So I attempted to use the sequencer batch rendering that is covered a little in this wiki page:

https://wiki.unrealengine.com/Sequencer_Batch_Rendering

However no matter what I try I cannot actually get the batch file to actually start rendering out the movie.

The result I was getting was that my map would open, then my sequencer would play and it would have low frame rate just as if it was recording the frames to images, but when I checked in either the saved directory or attempted to set the folder path there would be no image sequences or movies saved anywhere.

Product Version: UE 4.12
Tags:
more ▼

asked Sep 29 '16 at 02:54 AM in Bug Reports

avatar image

Miroac
718 20 25 108

avatar image Matt.Williams Sep 30 '16 at 02:47 PM

Hi Miroac,

It would help to include what exactly you're entering into cmd or the batch file you're using so I can take a look. Note that this guide was made with 4.13 in mind. I did not test these methods very much in 4.12, but they should work.

-Matt W.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Matt,

I'm not sure what I changed but when I attempted with 4.12 at home but below is the cmd line I wrote in a scene I created using the starter content and this time is actually worked so I'm unsure what the issue was while at work.

Below is what I used that worked, I'll compare it with what I did at work when I'm in on Monday:

"C:\Program Files\Epic Games\4.12\Engine\Binaries\Win64\UE4Editor.exe" "D:\UE4 Projects\BatchSequenceTest\BatchSequenceTest.uproject" /Game/BatchTesting/Maps/TestMap -game -MovieSceneCaptureType="/Script/MovieSceneCapture.AutomatedLevelSequenceCapture" -LevelSequence="/Game/BatchTesting/Sequences/1stLevel" -MovieFrameRate=30 -noloadingscreen -resx=1280 -resy=720 -forceres -MovieFormat=BMP -MovieQuality=100 -notexturestreaming -MovieCinematicMode=yes -MovieWarmUpFrames=60 -MovieName="SH010.{frame}" -MovieFolder="D:\renderTests\SH010"

Now the only issue is that the guide doesn't include any information on how to render out any of the render pass options like Final Image, HDRColor and so on or how to render as EXR files.

more ▼

answered Sep 30 '16 at 02:59 PM

avatar image

Miroac
718 20 25 108

avatar image Miroac Sep 30 '16 at 03:11 PM

I was able to grab the cmd and it looks like I missed an / at the beginning of the LevelSequence portion of the command line. So now the only issue is the only thing I'm missing is how to render as EXR files

avatar image Matt.Williams Sep 30 '16 at 03:44 PM

Hey Miroac,

I'm trying to get the custom render pass stuff documented as well. Stay tuned.

-Matt W.

avatar image Miroac Sep 30 '16 at 04:01 PM

Ah awesome! I'm sick of getting stuck at work for crazy hours so this would be super helpful!

avatar image Matt.Williams Sep 30 '16 at 06:49 PM

Hey Miroac,

Just added a Custom Render Passes section to the wiki. Check it out!

-Matt W.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question